Bug 740699 - cpuscaling Traceback: NameError: global name 'Fase' is not defined
Summary: cpuscaling Traceback: NameError: global name 'Fase' is not defined
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.3
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-23 02:21 UTC by Guangze Bai
Modified: 2015-02-08 21:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-23 03:15:20 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Guangze Bai 2011-09-23 02:21:36 UTC
Description of problem:
v7 1.4 R27 cpuscaling backtraces:

Traceback (most recent call last):
  File "/usr/bin/v7", line 45, in <module>
    success = v7.do(args)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 193, in do
    result = self.commands[self.command]()
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 859, in doCertify
    return self._doRun(tests)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 715, in _doRun
    returnValue = self.runTest(tmpDirectory, test, run, outputFilePath)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 1132, in runTest
    rv = test.run()
  File "/usr/share/v7/tests/cpuscaling/cpuscaling.py", line 1067, in run
    if not self.runSubTest(self.runOnDemandTests, "On Demand, package %s" % package):
  File "/usr/share/v7/lib/v7/test.py", line 428, in runSubTest
    result = subtestFunction()
  File "/usr/share/v7/tests/cpuscaling/cpuscaling.py", line 917, in runOnDemandTests
    if not self.checkSpeedup(ondemandSpeedup, warn=False, maximumLimit=Fase):
NameError: global name 'Fase' is not defined

Version-Release number of selected component (if applicable):
v7-1.4-27



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Rob Landry 2011-09-23 03:08:21 UTC
Looking @ the source, the above seems to be fixed in v7-1.4-29

Comment 2 Caspar Zhang 2011-09-23 03:15:20 UTC
Guangze confirmed the issue is no longer existed in R29. Closing...


Note You need to log in before you can comment on or make changes to this bug.