Bug 740724 - [Virt-viewer] virt-viewer could not open guest with unix sockets
[Virt-viewer] virt-viewer could not open guest with unix sockets
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.2
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-23 01:53 EDT by Huming Jiang
Modified: 2011-12-06 10:07 EST (History)
4 users (show)

See Also:
Fixed In Version: virt-viewer-0.4.1-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 10:07:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Huming Jiang 2011-09-23 01:53:48 EDT
Description of problem:
virt-viewer could not open guest with unix sockets.


Version-Release number of selected component (if applicable):
libvirt-0.9.4-12.el6.x86_64
kernel-2.6.32-197.el6.x86_64
python-virtinst-0.600.0-3.el6.noarch
qemu-kvm-0.12.1.2-2.192.el6.x86_64
virt-viewer-0.4.1-5.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1.virsh edit demo
...
   <input type='mouse' bus='ps2'/>
   <graphics type='vnc' socket='/var/lib/libvirt/qemu/demo.vnc'/>
...
2. # vi /etc/libvirt/qemu.conf
enable vnc_auto_unix_socket = 1

3.# service libvirtd restart
Stopping libvirtd daemon:                                  [  OK  ]
Starting libvirtd daemon:                                  [  OK  ]

4. Start the guest
# virsh start demo
Domain demo started

5.#virt-viewer demo
Segmentation fault (core dumped)
6.Run virt-viewer -c qemu+ssh://10.66.93.194/system demo
Segmentation fault (core dumped)
  
Actual results:
As above.

Expected results:
Virt-viewer could open guest.

Additional info:
If i use virt-viewer-0.4.1-3.el6.x86_64 on both local and remote host, virt-viewer could open guest successfully. So this is a regression bug.
Comment 4 zhe peng 2011-09-28 22:54:36 EDT
this bug can reproduce with :
virt-viewer-0.4.1-5.el6

verify with 
virt-viewer-0.4.1-6.el6
libvirt-0.9.4-12.el6
qemu-kvm-0.12.1.2-2.192.el6

step:
1.virsh edit demo
...
   <input type='mouse' bus='ps2'/>
   <graphics type='vnc' socket='/var/lib/libvirt/qemu/rhel62.vnc'/>
...
2. # vi /etc/libvirt/qemu.conf
enable vnc_auto_unix_socket = 1

3.# service libvirtd restart
Stopping libvirtd daemon:                                  [  OK  ]
Starting libvirtd daemon:                                  [  OK  ]

4. Start the guest
# virsh start rhel62
Domain rhel62 started

5. #virt-viewer rhel62 --debug
** (virt-viewer:25584): DEBUG: fullscreen display 0: 0
** (virt-viewer:25584): DEBUG: fullscreen display 0: 0
** (virt-viewer:25584): DEBUG: Opening connection to libvirt with URI <null>

** (virt-viewer:25584): DEBUG: Add handle 5 1 0x89f450
** (virt-viewer:25584): DEBUG: Add timeout 0x89f990 -1 0x33496d89f0 0x89f330 1
** (virt-viewer:25584): DEBUG: notebook show status 0x83f050
** (virt-viewer:25584): DEBUG: notebook show status 0x83f050
** (virt-viewer:25584): DEBUG: Guest rhel62 is running, determining display

** (virt-viewer:25584): DEBUG: Set connect info: (null),(null),(null),(null),(null),(null),0
** (virt-viewer:25584): DEBUG: Guest rhel62 has a vnc display

** (virt-viewer:25584): DEBUG: Guest graphics address is /var/lib/libvirt/qemu/rhel62.vnc
** (virt-viewer:25584): DEBUG: Set connect info: localhost,(null),(null),(null),/var/lib/libvirt/qemu/rhel62.vnc,(null),0
** (virt-viewer:25584): DEBUG: Opening direct UNIX connection to display at /var/lib/libvirt/qemu/rhel62.vnc
** (virt-viewer:25584): DEBUG: notebook show status 0x83f050
** (virt-viewer:25584): DEBUG: notebook show status 0x83f050
** (virt-viewer:25584): DEBUG: notebook show display 0x83f050
** (virt-viewer:25584): DEBUG: Display size request 50x50 (desktop 100x100)
** (virt-viewer:25584): DEBUG: Allocated 400x375
** (virt-viewer:25584): DEBUG: Child allocate 375x375
** (virt-viewer:25584): DEBUG: desktop resize 1024x768
** (virt-viewer:25584): DEBUG: Preparing main window resize
** (virt-viewer:25584): DEBUG: Decided todo 1024x768 (desktop is 1024x768, fullscreen is 1680x1050
** (virt-viewer:25584): DEBUG: Display size request 1024x768 (desktop 1024x768)
** (virt-viewer:25584): DEBUG: Allocated 1024x768
** (virt-viewer:25584): DEBUG: Child allocate 1024x768
** (virt-viewer:25584): DEBUG: Display size request 50x50 (desktop 1024x768)
** (virt-viewer:25584): DEBUG: Allocated 1024x768
** (virt-viewer:25584): DEBUG: Child allocate 1024x768

the guest can opened and without error

6. # virt-viewer -c qemu+ssh://10.66.6.166/system rhel62

the guest can opened and without error

the bug fixed. verification passed.move to verified
Comment 5 errata-xmlrpc 2011-12-06 10:07:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1614.html

Note You need to log in before you can comment on or make changes to this bug.