Bug 740725 - sys_mmap: kernel panic while ltp compiling(task python blocked)
Summary: sys_mmap: kernel panic while ltp compiling(task python blocked)
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.1
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 6.1
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 846704
TreeView+ depends on / blocked
 
Reported: 2011-09-23 06:13 UTC by xiali
Modified: 2016-08-26 02:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-26 02:47:38 UTC


Attachments (Terms of Use)

Description xiali 2011-09-23 06:13:43 UTC
Description of problem:

Kernel Tier2 test, while ltp compiling, kernel panic.

INFO: task python:19290 blocked for more than 120 seconds. 
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message. 
python        D ffff880044552800  4224 19290   1541 0x00000080 
 ffff8800482efde8 0000000000000046 ffff8800482efd48 ffff8800482f1400 
 0000000000000000 0000000000000007 0000000000000006 ffff880044552800 
 ffff8800482f19c0 ffff8800482effd8 000000000000f688 ffff8800482f19c0 
Call Trace: 
 [<ffffffff810ac0dd>] ? trace_hardirqs_on_caller+0x14d/0x190 
 [<ffffffff8150df6d>] rwsem_down_failed_common+0x8d/0x1d0 
 [<ffffffff8109b705>] ? sched_clock_local+0x25/0x90 
 [<ffffffff8150e0d3>] rwsem_down_write_failed+0x23/0x30 
 [<ffffffff81186e69>] ? khugepaged+0x309/0x1320 
 [<ffffffff812917a3>] call_rwsem_down_write_failed+0x13/0x20 
 [<ffffffff8150d16e>] ? down_write+0x8e/0xb0 
 [<ffffffff81144c9c>] ? sys_mmap_pgoff+0x5c/0x2d0 
 [<ffffffff81144c9c>] sys_mmap_pgoff+0x5c/0x2d0 
 [<ffffffff8150e232>] ? trace_hardirqs_on_thunk+0x3a/0x3f 
 [<ffffffff81010639>] sys_mmap+0x29/0x30 
 [<ffffffff8100b132>] system_call_fastpath+0x16/0x1b 
1 lock held by python/19290: 
 #0:  (&mm->mmap_sem){++++++}, at: [<ffffffff81144c9c>] sys_mmap_pgoff+0x5c/0x2d0 
general protection fault: 0000 [#1] SMP  
last sysfs file: /sys/devices/virtual/block/dm-0/dm/name 
CPU 0  
Modules linked in: tun sunrpc cpufreq_ondemand powernow_k8 freq_table ipv6 dm_mirror dm_region_hash dm_log microcode edac_core edac_mce_amd k8temp hwmon shpchp sg forcedeth snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc i2c_nforce2 ext4 mbcache jbd2 sd_mod crc_t10dif sr_mod cdrom ata_generic pata_acpi sata_nv nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core video output dm_mod [last unloaded: scsi_wait_scan] 
 
Modules linked in: tun sunrpc cpufreq_ondemand powernow_k8 freq_table ipv6 dm_mirror dm_region_hash dm_log microcode edac_core edac_mce_amd k8temp hwmon shpchp sg forcedeth snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc i2c_nforce2 ext4 mbcache jbd2 sd_mod crc_t10dif sr_mod cdrom ata_generic pata_acpi sata_nv nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core video output dm_mod [last unloaded: scsi_wait_scan] 
Pid: 27, comm: khungtaskd Not tainted 2.6.32-131.15.1.el6.x86_64.debug #1 NY801AV-ABA p6100z 
RIP: 0010:[<ffffffff810e8650>]  [<ffffffff810e8650>] watchdog+0xd0/0x2b0 
RSP: 0018:ffff88003756be60  EFLAGS: 00010216 
RAX: 6b6b6b6b6b6b6b6b RBX: 6b6b6b6b6b6b660b RCX: 0000000000000007 
RDX: 0000000000000470 RSI: ffff88003756d058 RDI: 0000000000000286 
RBP: ffff88003756beb0 R08: 0000000000000000 R09: 0000000000000000 
R10: ffff880071ad1150 R11: 0000000000000000 R12: 0000000000000078 
R13: ffff880071ad1140 R14: 00000000000003ff R15: 00000000003ffbff 
FS:  00007f6888b2c700(0000) GS:ffff880004e00000(0000) knlGS:0000000000000000 
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b 
CR2: 00000035dca74550 CR3: 0000000019615000 CR4: 00000000000006f0 
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000 
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400 
Process khungtaskd (pid: 27, threadinfo ffff88003756a000, task ffff88003756c6c0) 
Stack: 
 ffffffff810e8680 0000000000000286 ffff8800756e7db0 ffff880071ad1150 
<0> ffff88003756beb0 ffff8800756e7d90 ffff88003756bec8 ffffffff810e8580 
<0> 0000000000000000 0000000000000001 ffff88003756bf40 ffffffff81093de6 
Call Trace: 
 [<ffffffff810e8680>] ? watchdog+0x100/0x2b0 
 [<ffffffff810e8580>] ? watchdog+0x0/0x2b0 
 [<ffffffff81093de6>] kthread+0x96/0xa0 
 [<ffffffff8100c28a>] child_rip+0xa/0x20 
 [<ffffffff8100bbd0>] ? restore_args+0x0/0x30 
 [<ffffffff81093d50>] ? kthread+0x0/0xa0 
 [<ffffffff8100c280>] ? child_rip+0x0/0x20 
Code: 57 57 fc ff 4d 8b ad 48 04 00 00 49 81 ed 48 04 00 00 49 81 fd 20 50 80 81 0f 84 cc 01 00 00 4d 8d 55 10 4c 89 eb eb 23 0f 1f 00 <48> 8b 03 48 83 f8 02 0f 84 dd 00 00 00 48 8b 9b 60 05 00 00 48  
RIP  [<ffffffff810e8650>] watchdog+0xd0/0x2b0 
 RSP <ffff88003756be60> 
---[ end trace 35a18856386b373e ]--- 
Kernel panic - not syncing: Fatal exception 
Pid: 27, comm: khungtaskd Tainted: G      D    ----------------   2.6.32-131.15.1.el6.x86_64.debug #1 
Call Trace: 
 [<ffffffff8150acbd>] ? panic+0x78/0x148 
 [<ffffffff81510174>] ? oops_end+0xe4/0x100 
 [<ffffffff8100f43b>] ? die+0x5b/0x90 
 [<ffffffff8150fd42>] ? do_general_protection+0x162/0x170 
 [<ffffffff8150f2e5>] ? general_protection+0x25/0x30 
 [<ffffffff810e8650>] ? watchdog+0xd0/0x2b0 
 [<ffffffff810e8680>] ? watchdog+0x100/0x2b0 
 [<ffffffff810e8580>] ? watchdog+0x0/0x2b0 
 [<ffffffff81093de6>] ? kthread+0x96/0xa0 
 [<ffffffff8100c28a>] ? child_rip+0xa/0x20 
 [<ffffffff8100bbd0>] ? restore_args+0x0/0x30 
 [<ffffffff81093d50>] ? kthread+0x0/0xa0 
 [<ffffffff8100c280>] ? child_rip+0x0/0x20 
panic occurred, switching back to text console 




Version-Release number of selected component (if applicable):
2.6.32-131.15.1.el6.x86_64.debug

How reproducible:
hardly
  
Actual results:
kernel panic

Expected results:
no panic

Additional info:
job:
https://beaker.engineering.redhat.com/jobs/132513
log:
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2011/09/1325/132513/274885//console.log

Comment 2 RHEL Product and Program Management 2011-10-07 15:49:57 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 3 RHEL Product and Program Management 2012-12-14 07:40:44 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 Linda Wang 2016-08-26 02:47:38 UTC
So far we can't reproduced the issue above. 
Therefore, closing off this BZ, and if this issue
ever happened again, please feel free to reopen this bz.

Many thanks!


Note You need to log in before you can comment on or make changes to this bug.