Bug 740749 - No root device "..." found with initramfs created by dracut in RHEL6.2-20110921.1 on xen guest
Summary: No root device "..." found with initramfs created by dracut in RHEL6.2-20110...
Keywords:
Status: CLOSED DUPLICATE of bug 740786
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-23 08:21 UTC by Yuyu Zhou
Modified: 2011-09-23 13:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-23 13:26:20 UTC


Attachments (Terms of Use)
RHEL6.2-20110921.1_pv.log (9.83 KB, text/plain)
2011-09-23 08:23 UTC, Yuyu Zhou
no flags Details
RHEL6.2-20110921.1_HVM.png (20.01 KB, image/png)
2011-09-23 08:23 UTC, Yuyu Zhou
no flags Details

Description Yuyu Zhou 2011-09-23 08:21:55 UTC
Description of problem:
RHEL6.2 guest crash on RHEL5.7 xen host, both 32bit and 64bit, both HVM and PV

Version-Release number of selected component (if applicable):
guest: kernel-2.6.32-201.el6
host: xen-3.0.3-134.el5
      kernel-2.6.18-274.el5

How reproducible:
100%

Steps to Reproduce:
1. Install a HVM and a PV guest from RHEL6.2-20110921.1 tree (kernel-2.6.32-201.el6).
2. Boot the PV guest.
3. Boot the HVM guest with "tap:aio+xvda" disk param.
4. Boot the HVM guest with "file+hda" disk param and with xen_emul_unplug=never in guest kernel command line.
  
Actual results:
1. For step 2, the guest crash with the init process killed, show in RHEL6.2-20110921.1_pv.log.
2. For step 3, the guest crash at the same step as pv guest:
Kernel panic - not syncing: Attempted to kill init! 
Pid: 1, comm: init Not tainted 2.6.32-201.el6.x86_64 #1
3. For step 4, the guest crash as RHEL6.2-20110921.1_HVM.png show.

Expected results:
The guest should be boot successfully at any of the three condition.

Additional info:
The RHEL6.2-20110921.1 boot successfully in baremetal machine.

Comment 1 Yuyu Zhou 2011-09-23 08:23:00 UTC
Created attachment 524552 [details]
RHEL6.2-20110921.1_pv.log

Comment 2 Yuyu Zhou 2011-09-23 08:23:38 UTC
Created attachment 524553 [details]
RHEL6.2-20110921.1_HVM.png

Comment 4 Yuyu Zhou 2011-09-23 09:31:40 UTC
Additional info:
1. Install HVM or PV guest from RHEL6.2-20110907.1 tree(kernel-2.6.32-195.el6), the guest works well after installation.

2. Upgrade the RHEL6.2-20110907.1 guest's kernel to kernel-2.6.32-201.el6, the guest can boot successfully.

Comment 5 Igor Mammedov 2011-09-23 13:07:46 UTC
Something wrong with initrd that installer (and not the only installer) from RHEL6.2-20110921.1 creates.

I've tried to install it on intel-mahobay-01.lab.bos.redhat.com while testing xen's smep patches:

 virt-install -p -n rh62 -r 1024 -s 6 -f /var/lib/xen/images/rh62pv --nographics -l http://download.lab.bos.redhat.com/rel-eng/RHEL6.2-20110921.1/6.2/Server/x86_64/os

1.
And have the same panic with guest log similar to RHEL6.2-20110921.1_pv.log.
Then I've copied 61 kernel and initrd to that vm and booted it successfully.

2. Manual creation of initrd, on installed RHEL6.2-20110921.1,  doesn't helped either.

3. initrd created on rhel6.1 guest for RHEL6.2-20110921.1 kernel is correct, and I can boot guest with 2.6.32-201 kernel. And log has message:

  blkfront: xvda: barriers disabled
   xvda: xvda1 xvda2
=>  dracut: Scanning devices xvda2 for LVM logical volumes vg_dhcp472/lv_root vg_dhcp472/lv_swap

whether guest that failed to boot doesn't have it.

So it is not kernel bug but rather dracut bug.
Changing component to dracut.

Comment 6 Harald Hoyer 2011-09-23 13:26:20 UTC

*** This bug has been marked as a duplicate of bug 740786 ***


Note You need to log in before you can comment on or make changes to this bug.