Bug 740758 - RHEL5u7 guest can't recognize hotplugged interface
Summary: RHEL5u7 guest can't recognize hotplugged interface
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-23 09:22 UTC by Vivian Bian
Modified: 2011-09-23 09:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-23 09:35:26 UTC


Attachments (Terms of Use)

Description Vivian Bian 2011-09-23 09:22:31 UTC
Description of problem:


Version-Release number of selected component (if applicable):
libvirt-0.9.4-12.el6.x86_64
qemu-kvm-0.12.1.2-2.192.el6.x86_64
kernel-2.6.32-197.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1. install guest with tree  RHEL5.7-Server-20110622.0
2. start the guest
3. try to attach interface to guest with following two commands
   a.   # virsh attach-interface rhel57-new network default vnet0 --model e1000
   b.   # virsh attach-device rhel57-new interface.xml
        # cat interface.xml
        <interface type='bridge'>
           <source bridge='virbr0'/>
           <model type='virtio'/>
        </interface>

Actual results:
both of the two commands got success to attach the interface to rhel5u7 guest , but without reboot the guest , guest won't recognize the interface automatically
Besides, after shutdown guest, attached device xml won't be removed from guest xml file. 

Expected results:
guest can recognize attached interface automatically without reboot .

Additional info:
rhel6 guest won't encounter this problem . 
And for rhel5u7 guest, attach virtio disk device doesn't work as well .

Comment 2 Vivian Bian 2011-09-23 09:35:26 UTC
load acpiphp in the RHEL5u7 guest will resolve the problem . Since it is expected , close this bug as NOTABUG


Note You need to log in before you can comment on or make changes to this bug.