Bug 740775 - virt-manager should hide unsupported serial types
Summary: virt-manager should hide unsupported serial types
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-23 10:09 UTC by min zhan
Modified: 2012-06-20 12:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed
Clone Of:
Environment:
Last Closed: 2012-06-20 12:36:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0785 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2012-06-19 20:34:46 UTC

Description min zhan 2011-09-23 10:09:58 UTC
Description of problem:
From bug 720635 Comment 7 and bug 740478 Comment 9, udp and pipe are not supported types. virt-manager should hide them.

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-6.el6

How reproducible:
Always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
they are listed in virt-manager serial options.

Expected results:
virt-manager should hide the unsupported ones.

Additional info:

Comment 2 Cole Robinson 2011-09-27 15:54:07 UTC
Not a huge priority so deferring to 6.3

Comment 4 Cole Robinson 2012-02-01 20:03:50 UTC
Fixed in virt-manager-0.9.0-8.el6

Comment 7 Cole Robinson 2012-02-13 15:02:12 UTC
zhe peng, Since the quote from DV in that bug comes from a qemu dev, I assume at the qemu level they are not supporting the functionality, so disabling it in the UI is probably the best idea. Users can't still create it by hand in the XML if they desire.

Comment 8 zhe peng 2012-02-14 01:08:04 UTC
thanks cole

verify with :
virt-manager-0.9.0-9.el6
python-virtinst-0.600.0-7.el6

udp and pipe removed from serial device type,verification passed,move to verified.

Comment 9 Cole Robinson 2012-06-12 15:25:43 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed

Comment 11 errata-xmlrpc 2012-06-20 12:36:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0785.html


Note You need to log in before you can comment on or make changes to this bug.