Bug 740840 - usbfs not mounted to /proc/bus/usb
Summary: usbfs not mounted to /proc/bus/usb
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 16
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-23 14:09 UTC by Lane
Modified: 2012-04-14 17:43 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-24 23:20:34 UTC


Attachments (Terms of Use)

Description Lane 2011-09-23 14:09:39 UTC
Description of problem:
I installed Fedora 16 alpha and ran all the updates. Upon trying to launch virtualbox, however, it complained about usbfs not being present (although it was a very cryptic message). I manually mounted usbfs with the command 'mount -t usbfs usbdevfs /proc/bus/usb', and virtualbox was happy. usbfs automatically mounts on F15, but I could not find where that is done in searching through the /etc directory on a F15 install. So I am not sure which rpm this problem belongs to. I also do not know if this is an isolated problem to my one machine or if this was an intentional change. I could not find any documentation stating this was an intentional change anywhere.

Version-Release number of selected component (if applicable):
F16 alpha

How reproducible:
I have only tried F16 alpha on one machine. It happened on that one machine. I cannot say whether if others are having the same problem.

Steps to Reproduce:
1. Install F16 alpha and see that /proc/bus/usb is not mounted.

Comment 1 Kay Sievers 2011-09-23 19:11:10 UTC
usbfs is deprecated since years and should no longer be used by anything.

Comment 2 Lane 2011-09-23 19:51:01 UTC
Is there reason no longer mount it by default? Like a performance or compatibility problem?

virtual box still uses it.

What was the old mechanism for mounting it? I can certainly add something to whatever the systemd equivalent of /etc/rc.local is, but I would like to know the old method a well.

Comment 3 Kay Sievers 2011-09-23 20:02:40 UTC
Just add it to /etc/fstab, it will be mounted then.

Nothing should use it though, in the future, it will eventually be
removed from the kernel. If you care enough, it would be nice it you
can file a bug against virtual box.

Comment 4 Lennart Poettering 2011-09-24 23:20:34 UTC
There's nothing to fix in systemd here. VirtualBox should be fixed, please file a bug. And as a work-around add the mount to /etc/fstab. Closing.

Comment 5 rob.dyck 2011-11-12 00:52:31 UTC
I had a similar problem with the Samsung Unified Driver. The Sane interface could not detect my scanner because the backend "smfp" relies on the usbfs. This is a proprietary driver. It's anybody's guess whether it is possible to get Samsung to revise the driver.

Driver version 3.00.65 dated Nov 18 2009.

Comment 6 zimon 2012-04-14 17:29:52 UTC
Also the program and package usbview wants usbfs mounted.

# rpm -q usbview
usbview-1.1-5.fc15.x86_64

Comment 7 Kay Sievers 2012-04-14 17:43:49 UTC
It is expected, that usbfs will be removed from the kernel sooner than later.

Packages still relying on the plain and deprecated usbfs and not using libusb,
which handles that transparently, need to be converted.

Usbview is also outdated and unmaintained, and should probably be removed from
the distribution.


Note You need to log in before you can comment on or make changes to this bug.