Bug 740888 - [ipa webui] Searching will find an object for a field/setting that matched this criteria, but is not displayed
Summary: [ipa webui] Searching will find an object for a field/setting that matched th...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Rob Crittenden
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: 756082
TreeView+ depends on / blocked
 
Reported: 2011-09-23 16:21 UTC by Namita Soman
Modified: 2012-02-27 07:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-27 07:43:21 UTC


Attachments (Terms of Use)

Description Namita Soman 2011-09-23 16:21:40 UTC
Description of problem:
In HBAC Rules. search for the leter 'm', and allow_all will be listed, because its description contains 'from'. But the page doesn't display description, and so the user is left confused as to why this rule is displayed. 

Or if a rule is added, and it applies to a host whose name contains 'm', then the search will find this rule too.

Search should be limited to the fields that are displayed to avoid confusion.

Version-Release number of selected component (if applicable):
ipa-server-2.1.1-4.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Add and edit HBAC rule - test
2. Go to its Accessing section, and click to Add a Host
3. Add a host - say - example.testrelm
4. Go back to HBAC Rules page, and search for the letter 'm'
  
Actual results:
the rule 'test' is listed

Expected results:
the rule 'test' should not have matched the criteria


Additional info:

Comment 2 Rob Crittenden 2011-09-23 17:33:45 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/1855

Comment 4 Martin Kosek 2012-02-22 16:10:30 UTC
There were some further discussions about this issue on both CLI and WebUI side and we came to a common agreement. We think we do the right thing with searching for given term ('m' in your case) in all object's default attributes. Even if some field is not shown (in WebUI) that does not necessarily mean that user would not want to search the term in such field.

Talking specifically about description field, user could have his custom data in such field and would not like if he suddenly can't search in it. That would sound more like a regression IMO. I plan to close this bug as WONTFIX if nobody protests.

Comment 5 Martin Kosek 2012-02-27 07:43:21 UTC
Closing the BZ as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.