Bug 740913 - PAPI testsuite hangs on POWER7 box
Summary: PAPI testsuite hangs on POWER7 box
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.2
Hardware: ppc64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Steve Best
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 767187
TreeView+ depends on / blocked
 
Reported: 2011-09-23 18:37 UTC by Petr Muller
Modified: 2016-09-20 02:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-30 17:29:25 UTC


Attachments (Terms of Use)

Description Petr Muller 2011-09-23 18:37:55 UTC
Description of problem:
On POWER7 box I observe some testcases do not terminate even after running for tens of minutes. Those testcases usually spin the CPUs to 100%, and do not respond even to kill -9. 

Version-Release number of selected component (if applicable):
papi-4.1.3-3.el6.ppc64

How reproducible:
seems always

Steps to Reproduce:
1. either run /tools/papi/testsuite from Beaker, or install PAPI srpm and run the testsuite manually
  
Actual results:
see ctests/attach2 running for a long time 

Expected results:
testsuite terminates in tens of minutes

Additional info:
This is not a regression: old PAPI hangs too when it's testsuite is run on POWER7 box.

Comment 2 William Cohen 2011-09-27 16:51:03 UTC
Able to replicate this problem with the upstream papi from the cvs repository.

Comment 3 William Cohen 2011-09-30 01:03:57 UTC
Noticing that other ctests tests also hang such as:

byte_profile
calibrate
ipc

I suspect there is something going wrong in kernel space. One can not kill the hung tests. Also test program does not die when log out and then back in.

I did an strace of various tests and things seem to wrong after getting ioctl for performance monitoring like the something like the following:

ioctl(3, 0x20002400, 0)                 = 0


It doesn't look like perf perf works either on power7. The following also hangs:

perf stat ls

However, maybe this is to previous problems with the papi tests.

Comment 4 RHEL Product and Program Management 2011-10-07 15:50:05 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 5 Petr Muller 2011-10-10 13:01:21 UTC
Not a regression, proposing for 6.3

Comment 7 Steve Best 2012-02-17 20:42:54 UTC
Petr,

could you try this on 6.3 kernel 229 or later. I did a perf fix in that kernel and it should fix the hang issue.

-Steve

Comment 8 RHEL Product and Program Management 2012-05-03 04:44:29 UTC
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.


Note You need to log in before you can comment on or make changes to this bug.