Bug 740949 - RFE: Make "rhgb quiet" the last options again
Summary: RFE: Make "rhgb quiet" the last options again
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 742169
TreeView+ depends on / blocked
 
Reported: 2011-09-23 20:58 UTC by Kamil Páral
Modified: 2014-09-30 23:40 UTC (History)
5 users (show)

Fixed In Version: anaconda-17.1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 742169 (view as bug list)
Environment:
Last Closed: 2012-02-14 11:57:25 UTC


Attachments (Terms of Use)
default grub2 config (10.92 KB, image/png)
2011-09-23 20:58 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2011-09-23 20:58:40 UTC
Created attachment 524687 [details]
default grub2 config

Description of problem:
In Fedora 15 and earlier, the "rhgb quiet" kernel boot options were always the last ones on the kernel line in the generated grub.cfg. It was easy to delete them if you needed that.

In Fedora 16 with grub2, these two options are randomly dispersed on the command line. It takes time before you locate them and then delete them. Please have a look at the attached picture and measure the time you need to locate both "rhgb" and "quiet" options. It was 10 seconds for me.

As a Fedora QA team member, I use to delete them quite often to get some debugging output (OTOH, I need to also test when they are present, so I can't just adjust grub or something). I would be very glad if you could restore the previous behavior and make them the last two options again. It saves so much time.

It's not just about QA. On many wiki pages and troubleshooting guides we advise the users to delete these two like to help them debug their problems (e.g. hardware problems). In this case it would also help to have these two options together and easily accessible.

I was told that these options are dispersed because you keep them in a Python set (which doesn't keep order). I am sure this can easily implemented while keeping the desired order. For example for filtering out duplicates out of the list while keeping order, you can use list comprehensions or OrderedDict class.

Version-Release number of selected component (if applicable):
anaconda 16.17

How reproducible:
always

Comment 1 Ales Kozumplik 2011-09-26 08:09:38 UTC
I am working on a similar bug (bug 740222) in this area. Will look into this too once I get around to it.

Comment 2 Ales Kozumplik 2011-09-29 08:21:41 UTC
Patch has been posted for review: https://www.redhat.com/archives/anaconda-devel-list/2011-September/msg00225.html

I do not plan this for f16.

Comment 3 Ales Kozumplik 2011-10-04 07:52:21 UTC
Fixed by dde941ffe4092098889df88c399dbd550e5fec32.

Comment 4 Kamil Páral 2012-02-14 11:57:25 UTC
Confirmed fixed in F17 Alpha TC2.


Note You need to log in before you can comment on or make changes to this bug.