Bug 741096 - [webadmin] Selection lost when selecting a sub-tab
Summary: [webadmin] Selection lost when selecting a sub-tab
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: unspecified
Hardware: All
OS: All
unspecified
medium
Target Milestone: m2
: 3.1
Assignee: Gilad Chaplik
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-25 10:20 UTC by Danny Rankevich
Modified: 2015-06-19 05:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-09 07:57:24 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Danny Rankevich 2011-09-25 10:20:40 UTC
Description of problem:
When you select a sub-tab, and wait for the timer to reload it, the model selection is lost.
You see the selection visually, but getSeletedItems() returns null

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. login
2. go to the DC => Storage sub-tab
3. select a row, and then try to detach the storage
4. storage will not detach because of a NPE

Expected results:
getSeletedItems() must return the selection.

Additional info:

Comment 3 Itamar Heim 2012-08-09 07:57:24 UTC
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/


Note You need to log in before you can comment on or make changes to this bug.