Bug 741150 - No one but root can login via Gnome 3
Summary: No one but root can login via Gnome 3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 02:02 UTC by David Highley
Modified: 2011-10-06 03:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-06 03:08:42 UTC


Attachments (Terms of Use)
/var/log/messages fragment (69.72 KB, text/plain)
2011-09-26 02:02 UTC, David Highley
no flags Details

Description David Highley 2011-09-26 02:02:41 UTC
Created attachment 524820 [details]
/var/log/messages fragment

Description of problem:
All logins but root fail for system through the Gnome 3 login process.

Version-Release number of selected component (if applicable):
systemd-35-1.fc16.x86_64
dbus-1.4.10-3.fc16.x86_64

How reproducible:
Every login

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
All accounts except root have nfs automounted home directories and use NIS auto.home to find mapping. Attached /var/log/messages.log fragment with information about login.

Comment 1 Michal Schmidt 2011-09-26 08:18:53 UTC
Do the logins fails on virtual terminals too?

Comment 2 David Highley 2011-09-26 13:20:48 UTC
We can do ssh terminal logins, but have not been able to get tigervnc to work. We do not normally use vnc so we may not have it set up correctly but indicates it is not able to connect to port 111. Did check iptables and found no block there.

Comment 3 David Highley 2011-09-27 04:36:53 UTC
Just in case we did another test where we stopped autofs and nailed up the home directory mount. Tried another login and got as far as opening a Gnome terminal window before the something has gone wrong icon appeared and the session was over. Oddly after that we were not able to unmount the NFS share. At least it appeared to still be there but when we tried to list the contents of a tar file we got an error. Checked for processes accessing the mount with lsof and did not find any. Ended up rebooting to clear umount issue.

Just in case it would matter the; the NFS shared file system is xfs format from a Fedora 14 system and the client Fedora 16 is running ext4 for the root file system and mount point.

Comment 4 David Highley 2011-10-06 03:08:42 UTC
Installed the beta release of fedora 16. Still had login issue. Login seemed to get farther but hung. We did another check with the new install for selinux avc issues and found none. So we stopped autofs and nfs mounted the home directories. Then we tried another login which also failed, but this time we saw an avc logged against nfs access. We created a local selinux policy to allow the nfs access and were then able to login. We then unmounted the home directories and restarted autofs and did another login which also worked. So were going to close this call and open a new one against selinux once we can get the information. The new hardware we installed it on seems to have died.


Note You need to log in before you can comment on or make changes to this bug.