Bug 74125 - (G400) X server crashs when OpenOffice opens file
(G400) X server crashs when OpenOffice opens file
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: 75466 (view as bug list)
Depends On:
Blocks: 82777
  Show dependency treegraph
Reported: 2002-09-16 12:18 EDT by keith adamson
Modified: 2007-04-18 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-04-10 08:02:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
X crash log (24.70 KB, text/plain)
2002-09-16 12:19 EDT, keith adamson
no flags Details
/sbin/lspci -vn >pcilist (2.03 KB, text/plain)
2002-09-16 12:21 EDT, keith adamson
no flags Details
rpm -qa | sort >rpmlist (13.18 KB, text/plain)
2002-09-16 12:22 EDT, keith adamson
no flags Details
document to open in OpenOffice (15.00 KB, application/octet-stream)
2002-09-16 12:25 EDT, keith adamson
no flags Details
rerun "/sbin/lspci -vn >pcilist.root" as root (2.09 KB, text/plain)
2002-09-16 12:32 EDT, keith adamson
no flags Details
XF86Config (3.27 KB, text/plain)
2002-09-16 12:40 EDT, keith adamson
no flags Details
rpm -qa | sort >rpmlist (12.64 KB, text/plain)
2002-10-08 15:49 EDT, keith adamson
no flags Details
run "/sbin/lspci -vn >pcilist.root" as root (2.09 KB, text/plain)
2002-10-08 15:54 EDT, keith adamson
no flags Details
/etc/X11/XF86Config with dri (3.27 KB, text/plain)
2002-10-08 15:56 EDT, keith adamson
no flags Details

  None (edit)
Description keith adamson 2002-09-16 12:18:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
X server crashs when OpenOffice opens file

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open file foo.doc in OpenOffice

Actual Results:  X server crash

Expected Results:  Document should open

Additional info:

Happens on two systems that have Matrox G400
Comment 1 keith adamson 2002-09-16 12:19:59 EDT
Created attachment 76245 [details]
X crash log
Comment 2 keith adamson 2002-09-16 12:21:48 EDT
Created attachment 76246 [details]
/sbin/lspci -vn >pcilist
Comment 3 keith adamson 2002-09-16 12:22:45 EDT
Created attachment 76247 [details]
rpm -qa | sort >rpmlist
Comment 4 keith adamson 2002-09-16 12:25:21 EDT
Created attachment 76248 [details]
document to open in OpenOffice
Comment 5 keith adamson 2002-09-16 12:32:18 EDT
Created attachment 76249 [details]
rerun "/sbin/lspci -vn >pcilist.root" as root
Comment 6 keith adamson 2002-09-16 12:40:30 EDT
Created attachment 76250 [details]
Comment 7 Mike A. Harris 2002-09-21 06:21:50 EDT
Please update to XFree86 4.2.0-72 as 4.2.0-71 had a very serious
critical flaw.

If you disable DRI does the problem stop?

Also, try disabling 2D acceleration with "noaccel".

Please provide updated results with the above tests, then we can
troubleshoot further and hopefully find the problem.
Comment 8 keith adamson 2002-10-08 15:41:13 EDT
problem still exists on 8.0


Load  "dri

from /etc/X11/XF86Config prevents X crash on open of doc.
Comment 9 keith adamson 2002-10-08 15:49:30 EDT
Created attachment 79484 [details]
rpm -qa | sort >rpmlist
Comment 10 keith adamson 2002-10-08 15:54:52 EDT
Created attachment 79485 [details]
run "/sbin/lspci -vn >pcilist.root" as root
Comment 11 keith adamson 2002-10-08 15:56:27 EDT
Created attachment 79486 [details]
/etc/X11/XF86Config with dri
Comment 12 keith adamson 2002-10-08 16:19:38 EDT
also adding;

Option "noaccel"

to the "Device" section of /etc/X11/XF86Config prevents the crash as follows;

Section "Device"
        # no known options
        Identifier   "Matrox Millennium G400"
        Driver       "mga"
        VendorName   "Matrox Millennium G400"
        BoardName     "Matrox Millennium G400"
        Option "noaccel"

Comment 13 Mike A. Harris 2002-10-09 00:58:14 EDT
*** Bug 75466 has been marked as a duplicate of this bug. ***
Comment 14 Mike A. Harris 2002-11-24 04:28:08 EST
Try removing option noaccel and trying this instead:

Option "XaaNoScreenToScreenCopy" to Section "Device" in your

Does this also fix the problem?  If so please attach latest config+log
for further analysis.  Thanks.
Comment 15 Roderick Johnstone 2003-02-27 10:41:49 EST
Did anyone resolve this yet?

We also have the same problem (Matrox card, X server crash, and sometimes a
system halt) when opening a (different from the file referred to above) (Word)
document in openoffice 1.0.2 on redhat 7.3

I tried the Option "XaaNoScreenToScreenCopy" as suggested above and restarted X.
What happened was:

On opening document, X server crashes.
On restarting X server the file opens and displays fine.
On scrolling the document, the X server crashes
On restarting the X server, the document opens fine and scrolling works fine.

Restarted X server by hand, then
On opening the document the X server crashes
On restarting the X server the document opens fine but on scolling, the system

I also tried the noaccel option and that seems to fix it fine. The main problem
then is that the Xserver is so slow when running with either noaccel or

Roderick Johnstone

Note You need to log in before you can comment on or make changes to this bug.