Bug 741272 - can't enable kdump.service
Summary: can't enable kdump.service
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kexec-tools
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Young
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 801499
TreeView+ depends on / blocked
 
Reported: 2011-09-26 13:16 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 801499 (view as bug list)
Environment:
Last Closed: 2013-01-18 22:55:58 UTC


Attachments (Terms of Use)

Description Jiri Moskovcak 2011-09-26 13:16:37 UTC
Description of problem:
When trying to enable kdump.service, it ends up with:
[15:05:01 root@dhcp-25-200 crash]# systemctl enable kdump.service
Warning: unit files do not carry install information. No operation executed.

Version-Release number of selected component (if applicable):
kexec-tools-2.0.2-29.fc16.x86_64

How reproducible:
100%

 
Actual results:
the service is not enabled and the kernel core is not saved when kernel panics

Expected results:
saved core

Comment 1 Flos Lonicerae 2011-10-24 04:08:50 UTC
Yes, kdump service installed incorrectly.

Comment 2 Américo Wang 2011-11-11 08:31:04 UTC
Hi, Tom,

I assign this to you as you worked on the systemd scriptlets...

Comment 3 Orion Poplawski 2012-02-14 17:14:21 UTC
Américo -  I've check in the fix for this into devel (2.0.2-39).  I'll leave it up to you to backport how you want to F16/F17.

Comment 4 Américo Wang 2012-02-15 12:47:54 UTC
Great! Thanks, Orion!

Comment 6 Fedora Update System 2012-03-22 04:00:28 UTC
kexec-tools-2.0.2-29.3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kexec-tools-2.0.2-29.3.fc16

Comment 7 Fedora Update System 2012-03-24 00:35:47 UTC
Package kexec-tools-2.0.2-29.3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kexec-tools-2.0.2-29.3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4607/kexec-tools-2.0.2-29.3.fc16
then log in and leave karma (feedback).

Comment 8 jeremy.lael 2012-04-12 21:43:44 UTC
I updated to 2.0.2-29.3 and chkconfig/systemctl for kdump worked.

Comment 9 Fedora Admin XMLRPC Client 2012-04-16 06:13:04 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 10 Flavio Leitner 2012-06-12 18:23:18 UTC
I found the same issue and the test package indeed fixed it.
thanks
fbl

Comment 11 Fedora End Of Life 2013-01-17 02:14:15 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.