Bug 741292 - system-config-cluster removes __independent_subtree from services
Summary: system-config-cluster removes __independent_subtree from services
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster
Version: 5.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 807971
TreeView+ depends on / blocked
 
Reported: 2011-09-26 14:11 UTC by Petter Hassberg
Modified: 2013-01-08 07:23 UTC (History)
2 users (show)

Fixed In Version: system-config-cluster-1.0.57-14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-08 07:23:09 UTC


Attachments (Terms of Use)
fix (769 bytes, patch)
2012-05-23 16:09 UTC, Ryan McCabe
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0046 normal SHIPPED_LIVE system-config-cluster bug fix update 2013-01-07 15:28:12 UTC

Description Petter Hassberg 2011-09-26 14:11:25 UTC
Description of problem:
When editing a cluster with "__independent_subtree" on certain services already, after saving/propagating cluster configuration system-config-cluster will have stripped the "___independent_subtree" attribute.

Version-Release number of selected component (if applicable):
system-config-cluster-1.0.57-7

How reproducible:
100%

Steps to Reproduce:
1. create cluster config with __independent_subtree attr on for example a script ref (for example <script ref="dovecot" __independent_subtree="2"/>)
2. Edit that config with system-config-cluster, make arbitrary change to config and save config
3. __independent_subtree attr is now missing from cluster conf.
  
Actual results:
Functionality from independent subtree will be lost if propagating cluster conf through system-config-cluster

Expected results:
system-config-cluster to leave __independent_subtree attr as found before editing

Additional info:

Comment 2 RHEL Product and Program Management 2012-04-02 10:39:55 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 5 Ryan McCabe 2012-05-23 16:09:37 UTC
Created attachment 586393 [details]
fix

Note that this bug occurs only when the resource that has the subtree options set is a reference to a global resource. It can be worked around by creating the resources inline inside the service for the time being.

Comment 10 errata-xmlrpc 2013-01-08 07:23:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0046.html


Note You need to log in before you can comment on or make changes to this bug.