Bug 741298 - rpmlint is unaware of "BSD with attribution" License
rpmlint is unaware of "BSD with attribution" License
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
15
noarch Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 10:24 EDT by Sergio Belkin
Modified: 2011-10-22 04:27 EDT (History)
5 users (show)

See Also:
Fixed In Version: rpmlint-1.3-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-19 00:29:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Belkin 2011-09-26 10:24:00 EDT
Description of problem:


Version-Release number of selected component (if applicable):

rpmlint-1.2-1.fc15.noarch

How reproducible: Build a package 

Steps to Reproduce:
1. Write a spec file with tag License as follows
License: BSD with attribution
2. Build a package either with rpmbuild or mock
3.rpmlint -i -v /path/to/rpm/yourpackage.rpm
  
Actual results:

The value of this tag appears to be misspelled. Please double-check.

yourpackage.src: W: invalid-license BSD with attribution
The value of the License tag was not recognized.  Known values are: "AAL",
"Abstyles", "Adobe", "ADSL", "AFL", "AGPLv1", "AGPLv3", "AGPLv3 with
exceptions", "AMDPLPA", "AML", "AMPAS BSD", "APSL 2.0", "APSL 2.0+", "ARL",
"Artistic 2.0", "Artistic clarified", "ASL 1.0", "ASL 1.0+", "ASL 1.1", "ASL
1.1+", "ASL 2.0", "ASL 2.0+", "Barr", "BeOpen", "BitTorrent", "Boost", "BSD",
"BSD Protection", "BSD with advertising", "CATOSL", "CC0", "CeCILL",
"CeCILL-B", "CeCILL-C", "CDDL", "CNRI", "Condor", "Copyright only", "CPAL",
"CPL", "Crossword", "Crystal Stacker", "DOC", "Dotseqn", "dvipdfm", "ECL 1.0",
"ECL 2.0", "eCos", "EFL 2.0", "EFL 2.0+", "Entessa", "EPL", "ERPL", "EU
Datagrid", "EUPL 1.1", "Eurosym", "Fair", "FTL", "Giftware", "GL2PS", "Glide",
"gnuplot", "GPL+", "GPL+ or Artistic", "GPL+ with exceptions", "GPLv1", "GPLv2
or Artistic", "GPLv2+ or Artistic", "GPLv2", "GPLv2 with exceptions",
"GPLv2+", "GPLv2+ with exceptions", "GPLv3", "GPLv3 with exceptions",
"GPLv3+", "GPLv3+ with exceptions", "IBM", "IJG", "ImageMagick", "iMatix",
"Imlib2", "Intel ACPI", "Interbase", "ISC", "Jabber", "JasPer", "JPython",
"Knuth", "Latex2e", "LBNL BSD", "LGPLv2", "LGPLv2 with exceptions", "LGPLv2+",
"LGPLv2+ or Artistic", "LGPLv2+ with exceptions", "LGPLv3", "LGPLv3 with
exceptions", "LGPLv3+", "LGPLv3+ with exceptions", "Lhcyr", "libtiff",
"LLGPL", "Logica", "LPL", "LPPL", "mecab-ipadic", "MirOS", "MIT", "MIT with
advertising", "mod_macro", "Motosoto", "MPLv1.0", "MPLv1.0+", "MPLv1.1",
"MPLv1.1+", "MS-PL", "MS-RL", "Naumen", "NCSA", "NetCDF", "Netscape",
"Newmat", "Newsletr", "NGPL", "Nokia", "NOSL", "Noweb", "OML", "OpenLDAP",
"OpenPBS", "OpenSSL", "OReilly", "OSL 1.0", "OSL 1.0+", "OSL 1.1", "OSL 1.1+",
"OSL 2.0", "OSL 2.0+", "OSL 2.1", "OSL 2.1+", "OSL 3.0", "OSL 3.0+", "Phorum",
"PHP", "PlainTeX", "Plexus", "PostgreSQL", "psutils", "Public Domain",
"Python", "Qhull", "QPL", "Rdisc", "RiceBSD", "Romio", "RPSL", "Rsfs", "Ruby",
"Saxpath", "SCEA", "SCRIP", "Sendmail", "Sleepycat", "SISSL", "SLIB", "SNIA",
"SPL", "TCL", "Teeworlds", "Threeparttable", "TMate", "TOSL", "TPL", "UCD",
"Vim", "VNLSL", "VOSTROM", "VSL", "W3C", "Webmin", "Wsuipa", "WTFPL",
"wxWidgets", "Xerox", "xinetd", "XSkat", "YPLv1.1", "Zed", "Zend", "zlib",
"zlib with acknowledgement", "ZPLv1.0", "ZPLv1.0+", "ZPLv2.0", "ZPLv2.0+",
"ZPLv2.1", "ZPLv2.1+", "CDL", "FBSDDL", "GFDL", "IEEE", "LDPL", "OFSFDL",
"Open Publication", "Public Use", "CC-BY", "CC-BY-ND", "CC-BY-SA", "DMTF",
"DSL", "EFML", "Free Art", "GeoGratis", "Green OpenMusic", "OAL", "AMS",
"Arphic", "Baekmuk", "Bitstream Vera", "DoubleStroke", "Hershey", "IPA",
"Liberation", "Lucida", "MgOpen", "mplus", "OFL", "PTFL", "STIX", "Utopia",
"Wadalab", "XANO", "Redistributable, no modification permitted", "Freely
redistributable without restriction".


Expected results:

rpmlint should not be complaint at all about it. It has to recognize "BSD with attribution" as an approved license

Additional info:


http://fedoraproject.org/wiki/Licensing:Main#Software_License_List
Comment 1 Fedora Update System 2011-10-12 15:03:48 EDT
rpmlint-1.3-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rpmlint-1.3-2.fc15
Comment 2 Fedora Update System 2011-10-12 15:04:03 EDT
rpmlint-1.3-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rpmlint-1.3-2.fc14
Comment 3 Fedora Update System 2011-10-12 15:04:16 EDT
rpmlint-1.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rpmlint-1.3-2.fc16
Comment 4 Fedora Update System 2011-10-13 14:10:30 EDT
Package rpmlint-1.3-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpmlint-1.3-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14240
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-10-19 00:29:14 EDT
rpmlint-1.3-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2011-10-22 04:22:14 EDT
rpmlint-1.3-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2011-10-22 04:27:49 EDT
rpmlint-1.3-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.