Bug 741413 - When creating new entities (orgs, roles, etc.), left pane should autosort on update
Summary: When creating new entities (orgs, roles, etc.), left pane should autosort on ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Katello
Classification: Retired
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 1.x
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
: 750115 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 18:17 UTC by Corey Welton
Modified: 2012-08-21 16:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-21 16:25:11 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-09-26 18:17:00 UTC
Description of problem:
This smells familiar, but I am not sure....
When user adds one or more new role, they get added to the left pane. However, they are added to the bottom of the list and not sorted.  They are not sorted until user leaves role view and comes back

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create a new role, "orgadmin_role"
2.  Create a new role, "borgadmin_role"
3.  Assure that both of these appear in the lefthand role pane in the order they were created
4.  Navigate to dashboard
5.  Navigate back to Administration > Roles; View results
  
Actual results:
Upon navigating back to Roles, roles are magically sorted.

Expected results:
When new roles are added to left pane, the pane should be autosorted to have the role appear in the right place from the onset.

Additional info:
This actually appears to occur in many areas of the UI -- creating new Orgs, for example.  It seems to me this is something we've perhaps discussed before, but I wasn't able to find a bug for it.

Comment 1 Justin Sherrill 2012-03-28 19:10:25 UTC
Adding to the bottom was actually a bug, they should have been added at the top.  This is fixed in 803420.

We had discussed how to handle new items and we decided adding to the top was the best solution. 

If you sort and obey pagination you can easily create something that never shows up in the list (which would be confusing).   If you just added it and sorted it based on what was displayed that is also problematic, as the user could then extended scroll down causing things to be out of order again.  

If you have any thoughts on how to improve this further we're open ears.

Comment 2 Justin Sherrill 2012-03-28 19:11:50 UTC
*** Bug 750115 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Suchý 2012-08-21 16:25:11 UTC
Closing per #1.

If you disagree, please reopen.


Note You need to log in before you can comment on or make changes to this bug.