Bug 741438 - SELinux is preventing /usr/libexec/totem-plugin-viewer from 'create' accesses on the file orcexec.t54O9i.
Summary: SELinux is preventing /usr/libexec/totem-plugin-viewer from 'create' accesses...
Keywords:
Status: CLOSED DUPLICATE of bug 741436
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:16ef9a20f85a00ec162353c9f18...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 19:57 UTC by James Cape
Modified: 2011-09-27 13:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-27 13:22:01 UTC


Attachments (Terms of Use)

Description James Cape 2011-09-26 19:57:14 UTC
abrt version: 2.0.5.980
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.0-0.rc6.git0.3.fc16.x86_64
reason:         SELinux is preventing /usr/libexec/totem-plugin-viewer from 'create' accesses on the file orcexec.t54O9i.
time:           Mon Sep 26 14:57:00 2011

description:
:SELinux is preventing /usr/libexec/totem-plugin-viewer from 'create' accesses on the file orcexec.t54O9i.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that totem-plugin-viewer should be allowed create access on the orcexec.t54O9i file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep totem-plugin-vi /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                orcexec.t54O9i [ file ]
:Source                        totem-plugin-vi
:Source Path                   /usr/libexec/totem-plugin-viewer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           totem-mozplugin-3.1.4-1.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-32.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux orwell.ignore-your.tv
:                              3.1.0-0.rc6.git0.3.fc16.x86_64 #1 SMP Fri Sep 16
:                              12:26:22 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Mon 26 Sep 2011 02:55:33 PM CDT
:Last Seen                     Mon 26 Sep 2011 02:55:33 PM CDT
:Local ID                      d40cb7a7-8f39-4f2b-9412-812dbe1b1730
:
:Raw Audit Messages
:type=AVC msg=audit(1317066933.380:393): avc:  denied  { create } for  pid=18266 comm="totem-plugin-vi" name="orcexec.t54O9i" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file
:
:
:type=AVC msg=audit(1317066933.380:393): avc:  denied  { read write open } for  pid=18266 comm="totem-plugin-vi" name="orcexec.t54O9i" dev=dm-2 ino=314211 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1317066933.380:393): arch=x86_64 syscall=open success=yes exit=ETXTBSY a0=1934790 a1=c2 a2=180 a3=73 items=0 ppid=1 pid=18266 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=7 comm=totem-plugin-vi exe=/usr/libexec/totem-plugin-viewer subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-plugin-vi,mozilla_plugin_t,user_home_dir_t,file,create
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:#!!!! The source type 'mozilla_plugin_t' can write to a 'file' of the following types:
:# mozilla_plugin_tmp_t, nsplugin_home_t, user_fonts_cache_t, pulseaudio_home_t, mozilla_plugin_tmpfs_t, gnome_home_type
:
:allow mozilla_plugin_t user_home_dir_t:file { read write create open };
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:#!!!! The source type 'mozilla_plugin_t' can write to a 'file' of the following types:
:# mozilla_plugin_tmp_t, nsplugin_home_t, user_fonts_cache_t, pulseaudio_home_t, mozilla_plugin_tmpfs_t, gnome_home_type
:
:allow mozilla_plugin_t user_home_dir_t:file { read write create open };
:

Comment 1 Daniel Walsh 2011-09-27 13:22:01 UTC

*** This bug has been marked as a duplicate of bug 741436 ***


Note You need to log in before you can comment on or make changes to this bug.