Bug 74192 - upgrade from 7.3 to 8 upgrades kernel but not kernel-source
upgrade from 7.3 to 8 upgrades kernel but not kernel-source
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-17 12:42 EDT by Chris Ricker
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-25 17:00:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-09-17 12:42:40 EDT
I upgraded from 7.3 to 8.0.  The upgrade upgraded the kernel RPMs, but not the
kernel-source RPMs.

[kaboom@hanuman export]$ rpm -qa | grep ^kernel
kernel-doc-2.4.18-14
kernel-source-2.4.18-10
kernel-smp-2.4.18-14
kernel-utils-2.4-8.13
kernel-uml-2.4.18-14
kernel-pcmcia-cs-3.1.31-9
[kaboom@hanuman export]$ 

However, the old kernel-source RPM (2.4.18-10) will manually uninstall just fine:

[kaboom@hanuman export]$ sudo rpm -ev kernel-source
[kaboom@hanuman export]$ rpm -q kernel-source
package kernel-source is not installed
[kaboom@hanuman export]$
Comment 1 Jeremy Katz 2002-10-25 16:41:33 EDT
Were there any errors in the upgrade.log about upgrading kernel-source?
Comment 2 Chris Ricker 2002-10-25 17:00:05 EDT
no
Comment 3 Jeremy Katz 2002-10-31 18:36:32 EST
I can't reproduce this here at all with 8.0 or with our current trees
Comment 4 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.