Bug 741920 - switch ksm and binfmt to use systemd
switch ksm and binfmt to use systemd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-28 09:16 EDT by Paolo Bonzini
Modified: 2013-01-09 06:54 EST (History)
13 users (show)

See Also:
Fixed In Version: qemu-0.15.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-04 21:23:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch against git (17.78 KB, patch)
2011-09-28 09:17 EDT, Paolo Bonzini
no flags Details | Diff
patch to add [Install] and correct systemctl invocation (1.09 KB, patch)
2011-10-26 05:27 EDT, Paolo Bonzini
no flags Details | Diff

  None (edit)
Description Paolo Bonzini 2011-09-28 09:16:20 EDT
Attached patch replaces the ksm/ksmtuned init scripts with systemd units, and the qemu init scripts with files that are dropped in /usr/lib/binfmt.d.

 8 files changed, 159 insertions(+), 331 deletions(-)
Comment 1 Paolo Bonzini 2011-09-28 09:17:01 EDT
Created attachment 525337 [details]
patch against git
Comment 2 Fedora Update System 2011-10-21 16:56:11 EDT
qemu-0.15.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qemu-0.15.1-1.fc16
Comment 3 Fedora Update System 2011-10-21 20:10:14 EDT
Package qemu-0.15.1-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-0.15.1-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14698
then log in and leave karma (feedback).
Comment 4 Michael Scherer 2011-10-26 04:51:08 EDT
Not sure if this work as expected. I got this error message on qemu-common installation :
  Mise à jour    : 2:qemu-common-0.15.1-1.fc16.x86_64                      4/19 
Non-fatal POSTIN scriptlet failure in rpm package 2:qemu-common-0.15.1-1.fc16.x86_64
Operation failed: No such file or directory
Operation failed: No such file or directory
warning: %post(qemu-common-2:0.15.1-1.fc16.x86_64) scriptlet failed, exit status 1

# /bin/systemctl --global enable ksm.service
Operation failed: No such file or directory

And strace show that :
# strace -e open /bin/systemctl --global enable ksm.service
open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 3
open("/lib64/libselinux.so.1", O_RDONLY|O_CLOEXEC) = 3
open("/lib64/libcap.so.2", O_RDONLY|O_CLOEXEC) = 3
open("/lib64/libsystemd-daemon.so.0", O_RDONLY|O_CLOEXEC) = 3
open("/lib64/libdbus-1.so.3", O_RDONLY|O_CLOEXEC) = 3
open("/lib64/libpthread.so.0", O_RDONLY|O_CLOEXEC) = 3
open("/lib64/librt.so.1", O_RDONLY|O_CLOEXEC) = 3
open("/lib64/libc.so.6", O_RDONLY|O_CLOEXEC) = 3
open("/lib64/libdl.so.2", O_RDONLY|O_CLOEXEC) = 3
open("/lib64/libattr.so.1", O_RDONLY|O_CLOEXEC) = 3
open("/usr/lib/systemd/user/ksm.service", O_RDONLY|O_NOCTTY|O_NOFOLLOW|O_CLOEXEC) = -1 ENOENT (No such file or directory)
Operation failed: No such file or directory
[root@liliana misc]# ls /usr/lib/systemd/
user
[root@liliana misc]# ls /usr/lib/systemd/user/
bluetooth.target  exit.service  printer.target   sockets.target
default.target    exit.target   shutdown.target  sound.target
[root@liliana misc]# 

The --global do not appear on https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
Comment 5 Paolo Bonzini 2011-10-26 05:27:01 EDT
Created attachment 530262 [details]
patch to add [Install] and correct systemctl invocation

Reproducible here too, something must have changed in system{d,ctl} since I did the patches.
Comment 6 Fedora Update System 2011-11-04 21:23:16 EDT
qemu-0.15.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.