Bug 742112 - Problem with French-Canadian layout
Problem with French-Canadian layout
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-29 02:13 EDT by nomnex
Modified: 2011-11-08 05:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-23 21:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
using setxbmap command to swtich to "fr_ca" layout (default layout "jp") (50.86 KB, image/png)
2011-10-03 03:35 EDT, nomnex
no flags Details
switching layout in ibus from "jp" to "fr_ca" - keys not mapped (56.41 KB, image/png)
2011-10-03 03:36 EDT, nomnex
no flags Details
testing ibus commands (187.36 KB, image/png)
2011-10-10 02:42 EDT, nomnex
no flags Details
Print-screen 1: ibus "ca" altgr + keys not mapped (52.31 KB, image/png)
2011-10-18 10:35 EDT, nomnex
no flags Details
Print-screen 2: setxbmap "ca" altgr + keys mapped (53.89 KB, image/png)
2011-10-18 10:36 EDT, nomnex
no flags Details

  None (edit)
Description nomnex 2011-09-29 02:13:53 EDT
Description of problem:

First off, this is far beyond my level of understanding. I try to explain in an understandable way:

I use a JP notebook with a en_US OS. I usually type in English. Because I need to type French, I have set a Canadian French layout keyboard using a setxbmap command. When I push right "Ctrl+Shift" keys, the layout switch. All is fine.

Now, when I rely on ibus to input Japanese and french, switching from one language input to another (Alt+Shift), the Canadian-keyboard layout is not complete. Many of the keys are not mapped to the correct character.

e.g. the "[" and "]" char: I can type them using ibus (japanese-anthy) or/and when I switch layout using the setxbmpa command (ibus off). But I cannot type  them with ibus set to French-Canadian input.

I am not positive, but it appears only the basic keys (a-z, dead keys and usage signs) are correctly mapped on the fr_ca layout in ibus, andnot the full layout. Is this possible?

To sum up:

When I switch from "default US" to "fr_ca" (ibus is not in action), the "[" and "]" char are mapped to a different keys on the keyboard, but they are available.

Using ibus:

When I turn ibus on to input "jp", the same char "[" and "]" are still mapped on the same keys-all fine. If I switch to ibus "fr_ca" input, the "[" and "]" char are not mapped to anything on my keyboard. I have the same problem with several other keys not mapped to anything, or incorrectly mapped, on the Canadian-French layout

My apology if my explanation is not very clear. Or if I am doing something wrong (e.g. user mistake, or misunderstanding). 

Version-Release number of selected component (if applicable):

F-15 LXDE
IBus 1.3.99.20110908 (Japanese-anthy & Fr_ca inputs)


How reproducible:

always

Steps to Reproduce:
1. Set ibus with JP & Canadian input - add French-Canadian keyboard in advance pref (on a non Canadian keyboard)
2. Switch from JP to Fr_Ca, using Alt+Shift
3. Try the correspondent keys to a default Canadian keyboard, "[", "{", "]", "{", etc. most of them are not available, and some other key are changed,eg. ">" instead of the expected "}" 
  
Actual results:

using ibus and switching to the Canadian-French layout is incomplete on my system.

Expected results:


full layout change, using ibus with "fr_ca" (what setxbmap command does when I need to input French, and when the input method is switched off)

Additional info:
Comment 1 fujiwara 2011-09-30 04:29:54 EDT
At first, please try to use the latest ibus.
# yum install ibus

If you enable ibus-anthy, the keyboard layout is inherited from the system keyboard layout.
ibus-setup can modify the system keyboard layout but I'd recommend to use gnome-control-center at the moment.

% gnome-control-center region
If the default layout is 'jp', anthy layout is also 'jp'.
If the default layout is 'us', anthy layout is also 'us'.

Fedora 16 will be able to show the system keyboard layouts on ibus menu too.
Comment 2 nomnex 2011-10-03 03:33:39 EDT
(In reply to comment #1)
> At first, please try to use the latest ibus.
> # yum install ibus

it's the second time I read this recommendation along your answers, but -- unless to be wrong -- Fedora ibus repos is up to date (I use the f-repo to update ibus)

Name        : ibus
Arch        : i686
Version     : 1.3.99.20110817
Release     : 4.fc15
Size        : 1.8 M
Repo        : installed
From repo   : updates
Summary     : Intelligent Input Bus for Linux OS
URL         : http://code.google.com/p/ibus/
License     : LGPLv2+
Description : IBus means Intelligent Input Bus. It is an input framework for
            : Linux OS.

> If you enable ibus-anthy, the keyboard layout is inherited from the system
> keyboard layout.

So, here, it looks like there is a problem. When I set with the setxbmap command a "fr_ca", I have got the full layout (including the R-Alt key mapped keys).

When I use ibus, the right Alt key is not mapped to anything, and all the right-Alt key combo of the he "fr_ca" keyboard layout are not available.

I enclose 2 print-screens for more clarity:

1. in clear, the "fr_ca" keyboard layout (red=Shift key/ blue=right Alt key). That's what I've got when I use the setxbmap command

2. same layout with "error stamp marks". that's the "layout" I've got when I use i-bus "fr_ca". All the R-Alt key combo are not mapped (at least on my system).

To complicate even more the situation, there is no right ALT key on the Japanese keyboard notebooks, but I use a JP usb keyboard which has a right Alt key, and - as stated above - the right Alt key is correctly mapped when I switch to "fr_ca" using the setxbmap command, but it is not when I use ibus.
Comment 3 nomnex 2011-10-03 03:35:19 EDT
Created attachment 525990 [details]
using setxbmap command to swtich to "fr_ca" layout (default layout "jp")
Comment 4 nomnex 2011-10-03 03:36:15 EDT
Created attachment 525991 [details]
switching layout in ibus from "jp" to "fr_ca" - keys not mapped
Comment 5 fujiwara 2011-10-03 04:07:47 EDT
Please use ibus-1.4.0 or later.
# yum install --enablerepo=updates-testing ibus

(In reply to comment #2)
> To complicate even more the situation, there is no right ALT key on the
> Japanese keyboard notebooks, but I use a JP usb keyboard which has a right Alt
> key, and - as stated above - the right Alt key is correctly mapped when I
> switch to "fr_ca" using the setxbmap command, but it is not when I use ibus.

I don't expect to use setxkbmap. I'd ask to run 'gnome-control-center region' to set the default keyboard layout with options on GNOME desktop.
If you use no XKB configuration on another desktop, the default XKB setting must be called before ibus-daemon is called.
Comment 6 nomnex 2011-10-04 01:54:26 EDT
(In reply to comment #5)

> I don't expect to use setxkbmap. I'd ask to run 'gnome-control-center region'
> to set the default keyboard layout with options on GNOME desktop.
> If you use no XKB configuration on another desktop, the default XKB setting
> must be called before ibus-daemon is called.

I use the Fedora LXDE Spin. There is no 'gnome-control-center region' or similar application at my knowledge.

my default:

/etc/sysconfig/keyboard

KEYTABLE="jp106"
MODEL="jp106"
LAYOUT="jp"
KEYBOARDTYPE="pc"

I added a another keyboard layout "ca", as explained here:

https://wiki.archlinux.org/index.php/LXDE#Keyboard_layout

using method 1: /etc/xdg/lxsession/LXDE/autostart

This work without problem, as long as I am outside ibus (turn off input method).

When I configure ibus with the same layout "ca", and use it, some keys are not mapped (see print-screen: https://bugzilla.redhat.com/attachment.cgi?id=525991)

a. do you suggest to install 'gnome-control-center region' on my current DE LXDE. - is it compatible with my DE?

b. do you explain me that ibus on another destkop than Gnome (specifically, on a LXDE DE) is likely to produce some problems?

Forgive the confusion. I have installed the F-LXDE spin. I set ibus to have a second input language "fr" with a "ca" keyboard layout. Some keys are not mapped when I switch to this input language. I am not sure if I understand your answer, as what is not working, and what can (could) be done - if anything - on my side. Thanks.
Comment 7 fujiwara 2011-10-04 02:41:30 EDT
(In reply to comment #6)
> a. do you suggest to install 'gnome-control-center region' on my current DE
> LXDE. - is it compatible with my DE?
> 
> b. do you explain me that ibus on another destkop than Gnome (specifically, on
> a LXDE DE) is likely to produce some problems?

I mean if ibus is no problem on GNOME desktop in your laptop, I think your problem is not ibus but a configuration something because ibus doesn't change the behavior between desktops as ibus works on glib2 and dbus.
Then I'd asked you just to use GNOME since I guess it might be hard for you to find which configuration is wrong.
I don't see any problems in either GNOME and LXDE.
Comment 8 nomnex 2011-10-04 03:51:44 EDT
once again, thank you for you time on this problem.

Can you confirm 2 points:

1. do you have the full keys mapped (incl. the R-Alt key combinations) when you set ibus to Language "French"/Keyboard:"ca" on a LXDE DE?

NB: I would agree to a configuration problem and not bother on this bug report, but I have not 1, but 2 different notebooks set with a default F-15 LXDE DE. Both use ibus set to French language with "ca" keyboard input. On both notebooks, the R-Alt key combinations are not mapped. The same occurs when I create new user account.

2. Comment7: "I'd asked you just to use GNOME" = do you mean to install 'gnome-control-center region' on LXDE, or do you mean to install GNOME desktop, instead of LXDE?
Comment 9 fujiwara 2011-10-04 05:07:47 EDT
(In reply to comment #8)
> once again, thank you for you time on this problem.
> 
> Can you confirm 2 points:
> 
> 1. do you have the full keys mapped (incl. the R-Alt key combinations) when you
> set ibus to Language "French"/Keyboard:"ca" on a LXDE DE?

Yes, any XKB options could work in my env.

Do you enable the XKB options when you run ibus by manual?

1. Run im-chooser and disable ibus.
2. log in the desktop session again.
3. Check if XKB options work correctly.
% /usr/libexec/ibus-xkb --get
4. Run ibus by manual
% ibus-daemon --xim &
5. Check if XKB options work correctly.
% /usr/libexec/ibus-xkb --get

> 2. Comment7: "I'd asked you just to use GNOME" = do you mean to install
> 'gnome-control-center region' on LXDE, or do you mean to install GNOME desktop,
> instead of LXDE?

I mean to install GNOME desktop instead of LXDE to identify your problem.
Thanks.
Comment 10 nomnex 2011-10-10 02:04:30 EDT
from the above:

Command 1:
[mt@nh28d ~]$ /usr/libexec/ibus-xkb --get
layout: jp,ca
model: 
option: grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp
[mt@nh28d ~]$

Command 2:
[mt@nh28d ~]$ /usr/libexec/ibus-xkb --get
layout: jp,ca
model: 
option: grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp
[mt@nh28d ~]$ ibus-daemon --xim &
[1] 4038
[mt@nh28d ~]$ /usr/libexec/ibus-xkb --get
layout: jp,ca
model: 
option: grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp
[mt@nh28d ~]$

Everything seems to work fine, except that, I don't have full "fr_ca" keyboard layout on both computers: The Left-Alt key is not mapped to any key when I use i-bus.

Sorry, I cannot follow your advice installing GNOME shell. These computer are too old.

Anyway, thank you for your time. If it works on you end, and not on my end, it might be difficult to got further, at my level of knowledge.

Workaround: I turn off ibus method, and switch keyboard using the setxbmap command to get a full layout.
Comment 11 nomnex 2011-10-10 02:42:12 EDT
NB: I am not sure if this is relevant but, I just noticed that, after passing your commands, any ibus input language selection is ineffective for the session. 

I enclose a print screen: if I switch to JP input and type "konichiha" in the lxterminal windows, the roman characters are not converted in kana.

I will probably recover the input language after loggin-off/on?
Comment 12 nomnex 2011-10-10 02:42:53 EDT
Created attachment 527162 [details]
testing ibus commands
Comment 13 fujiwara 2011-10-11 05:52:44 EDT
(In reply to comment #10)
> option:
> grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp

It seems you don't specify any XKB options for Alt (I mean altwin:* options)
So I think your left Alt should be normal Alt.

If you run 'ibus-xkb --get' command again after you switch to "French (Canada)" on ibus menu, the output shows 'ca' correctly.

I checked Canadian French keyboard.
http://en.wikipedia.org/wiki/Keyboard_layout#Canadian_French_.28Quebec.29
The Left Alt is normal against right Alt. So if you type Alt_L + f on gedit, the File menu will be open. Alt_R is AltGR on Canadian_French.


> Sorry, I cannot follow your advice installing GNOME shell. These computer are
> too old.

Probably I'd like to close this bug since I think it's not a bug.
Comment 14 nomnex 2011-10-15 20:49:18 EDT
(In reply to comment #13)
> (In reply to comment #10)
> > option:
> > grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp
> 
> It seems you don't specify any XKB options for Alt (I mean altwin:* options)
> So I think your left Alt should be normal Alt.

yes, it does

> If you run 'ibus-xkb --get' command again after you switch to "French (Canada)"
> on ibus menu, the output shows 'ca' correctly.

yes, it does

> I checked Canadian French keyboard.
> http://en.wikipedia.org/wiki/Keyboard_layout#Canadian_French_.28Quebec.29
> The Left Alt is normal against right Alt. So if you type Alt_L + f on gedit,
> the File menu will be open. Alt_R is AltGR on Canadian_French.

> Probably I'd like to close this bug since I think it's not a bug.

sorry, but there is a problem. it'is not a user problem, and it is not a machine problem.

after installing lxde on 2 different PCs, ibus set with Japanese & the Canadian_french input reproduce the same behavior: the left Alt with the "fr_ca" is only mapped with the dead keys (accents: à, ç, ...) and basic punctuation keys (dot, comma,). Most of the other sings keys - see attachment in comment #4 - ( [,], \, ^, =, +) remain of the default layout (for instance "jp", on my system). 

as I have said, when I run a setxbmap command (outside ibus), by comparison, I have a full working keyboard layout (letters, dead key, signs).

this is the command I am using (it only allow me to switch keyboard layout outside ibus):
setxkbmap -option grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll jp,ca

you answered that you cannot reproduce the problem and all the keys, inc. the left Alt key, are correctly mapped on your end, when you switch to "ca_fr" in ibus, on a LXDE de.

in comment #1 you said:
> If you enable ibus-anthy, the keyboard layout is inherited from the system
> keyboard layout.

It is, but some of the keys mapped to the Alt_R (or GRAlt) remains mapped to a "JP" layout (see attachment in comment #4)

in comment #5 you said:

> If you use no XKB configuration on another desktop, the default XKB setting
> must be called before ibus-daemon is called.

I don't really understand this. however, it seems to me the keyboard layouts are already configured in the Fedora dist. (Gnome, LXDE, KDE, etc.) the only missing option in LXDE is a GUI configuration to have several different input layouts (what I achieved with the setxkbmap command).

it looks to me there is a conflict in ibus when I switch to "ca_fr" using a "jp" default layout.

I keep posting back, because I can reproduce the same problem onmy 2 computers. They have a completely different hardware, but the software configuration is identical: both are clean install of F-15 LXDE, with ibus set to "JP" default with "ca_fr" additional input.

On both machine the Alt_R key remains mapped to "jp" input for the sing keys described in comment 4# (keys mapped with a red dot)

It is certain that my configuration is uncommon. but let's say if I would install F-15 LXDE on a few more JP notebooks, and set ibus with the "fr_ca" input. the Alt_R key would reproduce the same behavior. So, wouldn't it apply as a bug?

Of course, I can wait until F-16, but I worry the issue remains. I had the same problem on F-14 already.

Sorry to be so insisting on this. Of course, if there is no solution, or if it involves a too great amount of work for a single user (I), I will live with it.

Thanks again.
Comment 15 nomnex 2011-10-15 22:35:57 EDT
I am still trying to understand what's wrong in the connection between ibus+ default jp layout + additional "ca" input.

1. when Ibus is turned off (turn off input method)

- default layout is "jp"
- using the setxkbmap command above, I can switch full "ca" layout (all key are working)

2. when Ibus is set to Japanese layout (Ctrl+Space, default input "Hiragana"):

- switching to "ca" in ibus = L_Alt keys is not mapped with many keys: ±@£¢¤¬¦²³¼½¾\][~{}\ (no input when I press them)

2. when Ibus is set to Japanese layout AND I use my combo R-Ctl+R-Shift to change layout (setxkbmap command)

- it creates a mix of hiragan input (ibus) + the "ca" dead keys (accents) - that's a mess. The "ca" signs keys ±@£¢¤¬¦²³¼½¾\][~{}\ don't produce input either.

It summaries what I experience, but I run out of idea.
Comment 16 fujiwara 2011-10-17 03:06:29 EDT
You changed the bug category.

(In reply to comment #14)
> sorry, but there is a problem. it'is not a user problem, and it is not a
> machine problem.

Probably I think the problem is the user problem.

> after installing lxde on 2 different PCs, ibus set with Japanese & the
> Canadian_french input reproduce the same behavior: the left Alt with the
> "fr_ca" is only mapped with the dead keys (accents: à, ç, ...) and basic
> punctuation keys (dot, comma,). Most of the other sings keys - see attachment
> in comment #4 - ( [,], \, ^, =, +) remain of the default layout (for instance
> "jp", on my system). 

The left Alt is not AltGR. 

> http://en.wikipedia.org/wiki/Keyboard_layout#Canadian_French_.28Quebec.29

To output ']', I think you need to use AltGR instead of left Alt with ca.


> as I have said, when I run a setxbmap command (outside ibus), by comparison, I
> have a full working keyboard layout (letters, dead key, signs).

I don't see any differences.

> this is the command I am using (it only allow me to switch keyboard layout
> outside ibus):
> setxkbmap -option grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll jp,ca

1. Run setxkbmap -option grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll jp,ca
2. Run ibus-daemon
Then ibus get the current keyboard layout with ibus-xkb:
% /usr/libexec/ibus-xkb --get
layout: jp,ca
model:
option: grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll
3. Choose ca layout
Then ibus runs ibus-xkb and sets the ca layout:
% /usr/libexec/ibus-xkb -l ca -o grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll
% /usr/libexec/ibus-xkb --get
layout: ca
model:
option: grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll

ibus just runs ibus-xkb so actually you can confirm the ibus behavior with the command line directly without ibus-daemon.

% ibus-xkb -l layout -m model -o options.

> It is, but some of the keys mapped to the Alt_R (or GRAlt) remains mapped to a
> "JP" layout (see attachment in comment #4)

What is some of keys?
Comment 17 nomnex 2011-10-18 10:33:46 EDT
(In reply to comment #16)

> Probably I think the problem is the user problem.
> The left Alt is not AltGR.  
> > http://en.wikipedia.org/wiki/Keyboard_layout#Canadian_French_.28Quebec.29
> To output ']', I think you need to use AltGR instead of left Alt with ca.

it is a user problem, if there is user action. So far there is no user action. I only set "ca" input in ibus, and that does not work as expected.

I enclose 2 print-screens.

1. read color: AltGR key and correspondent keys not mapped on my keyboard(s) with ibus set to "ca" input
2. blue color: AltGR key and correspondent keys mapped on my keyboard(s) when I use setxkbmap command "ca".

There must be an explanation. when I set "ca" with setxkbmap, my "Alt" key (japanese notebook keyboard layout & usb Japanese keyboard layout) is correctly mapped. It is not when I set "ca" in ibus.
 
> I don't see any differences.

I know. So there is a problem if the exact similar issue occur on the 2 notebooks I have, both with vanilla (default) settings.

> 1. Run setxkbmap -option grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll
> jp,ca

okay

> 2. Run ibus-daemon
> Then ibus get the current keyboard layout with ibus-xkb:
> % /usr/libexec/ibus-xkb --get
> layout: jp,ca
> model:
> option: grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll

[mt@nh28d LXDE]$ /usr/libexec/ibus-xkb --get
layout: jp,ca
model: 
option: grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp

> 3. Choose ca layout
> Then ibus runs ibus-xkb and sets the ca layout:
> % /usr/libexec/ibus-xkb -l ca -o
> grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll
> % /usr/libexec/ibus-xkb --get
> layout: ca
> model:
> option: grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll

[mt@nh28d LXDE]$ /usr/libexec/ibus-xkb --get
layout: ca
model: 
option: grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp


> ibus just runs ibus-xkb so actually you can confirm the ibus behavior with the
> command line directly without ibus-daemon.
> 
> % ibus-xkb -l layout -m model -o options.

Okay

Now, do you see something in the commands outputs above I don't see? Because, when I pass the command:

[mt@nh28d LXDE]$ /usr/libexec/ibus-xkb -l ca

the AltGR key is correctly mapped!!! (same as in the print-screen 2 in blue color).

I can type all the AltGR+mapped keys (in the open terminal window only. If another window gains focus, the settings "jp".)

When I pass the command:

/usr/libexec/ibus-xkb -l ca -o grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll

The Alt does not give any output (same as in the print-screen 1 in red color)
Comment 18 nomnex 2011-10-18 10:35:33 EDT
Created attachment 528820 [details]
Print-screen 1: ibus "ca" altgr + keys not mapped
Comment 19 nomnex 2011-10-18 10:36:33 EDT
Created attachment 528821 [details]
Print-screen 2: setxbmap "ca" altgr + keys mapped
Comment 20 nomnex 2011-10-18 10:38:57 EDT
edit comment #17:

I can type all the AltGR+mapped keys (in the open terminal window only. If
another window gains focus, the setting [REVERTS TO] "jp" default input.)
Comment 21 fujiwara 2011-10-18 21:43:42 EDT
(In reply to comment #17)
> it is a user problem, if there is user action. So far there is no user action.
> I only set "ca" input in ibus, and that does not work as expected.
k
I don't say the user action but I'd think your configuration was wrong for the desktop or the bug explanation was failed and I think it would be not a bug for ibus.

> There must be an explanation. when I set "ca" with setxkbmap, my "Alt" key
> (japanese notebook keyboard layout & usb Japanese keyboard layout) is correctly
> mapped. It is not when I set "ca" in ibus.

Now I think you have been mistaken to explain left Alt and right Alt. It would bore me a bit.

> [mt@nh28d LXDE]$ /usr/libexec/ibus-xkb -l ca
> 
> the AltGR key is correctly mapped!!! (same as in the print-screen 2 in blue
> color).
> 
> I can type all the AltGR+mapped keys (in the open terminal window only. If
> another window gains focus, the settings "jp".)
> 
> When I pass the command:
> 
> /usr/libexec/ibus-xkb -l ca -o
> grp:switch,grp:rctrl_rshift_toggle,grp_led:scroll
> 
> The Alt does not give any output (same as in the print-screen 1 in red color)

I have not thought to set XKB option per XKB engine. The system option will be set for any XKB engines.
I'd suggest to replace grp:rctrl_rshift_toggle with another toggle option in your system XKB settings. (e.g. grp:lctrl_lshift_toggle).
Comment 22 fujiwara 2011-10-18 21:46:21 EDT
(In reply to comment #20)
> edit comment #17:
> 
> I can type all the AltGR+mapped keys (in the open terminal window only. If
> another window gains focus, the setting [REVERTS TO] "jp" default input.)

Yes, it's the default behavior in ibus.
Comment 23 nomnex 2011-10-22 10:49:57 EDT
(In reply to comment #21)
> I don't say the user action but I'd think your configuration was wrong for the
> desktop or the bug explanation was failed and I think it would be not a bug for
> ibus.

but I install the F-15 LXDE Spin on 2 pc. the configuration is the default. so if it's a configuration problem, it's ibus-LXDE related. There is a glitch in the way either one anther handles the keyboard layout "ca". If I had a third notebook, I could reproduce it again.

I suspect it is only rarity of the specific setting (jp notebooks, lxde de + anthy with "ca" input)

> > There must be an explanation. when I set "ca" with setxkbmap, my "Alt" key
> > (japanese notebook keyboard layout & usb Japanese keyboard layout) is correctly
> > mapped. It is not when I set "ca" in ibus.
> 
> Now I think you have been mistaken to explain left Alt and right Alt. It would
> bore me a bit.

Thank you to have noticed. I meant "Right Alt" in the above paragraph. 
 
> I have not thought to set XKB option per XKB engine. The system option will be
> set for any XKB engines.

Could that be it? it seems ibus + gnome and ibus + lxde is different from the way the later handle keyboard layout switch? I am not sure. but truly something is wrong with the default LXDE + ibus configuration. It is probably a setting; but it is not a user setting, it is the default setting that creates the problem.

Would this problem be solved if you set XKB option per XKB engine, on light DE spin as LXDE with the specific language configuration "default en_us, keyboard jp + ca input"?

> I'd suggest to replace grp:rctrl_rshift_toggle with another toggle option in
> your system XKB settings. (e.g. grp:lctrl_lshift_toggle).

This I want to try. Can you give more details I searched /usr/share/X11/xkb file there is none. what's the path to the XKB file to edit on Fedora. Thank you. 

It would be great if I could have the RightAlt key mapped when I switch to "ca" input in iubs. Thanks again.
Comment 24 nomnex 2011-11-07 04:03:40 EST
(In reply to comment #23)
> (In reply to comment #21)
> > I don't say the user action but I'd think your configuration was wrong for the
> > desktop or the bug explanation was failed and I think it would be not a bug for
> > ibus.

Well, my apology for this one. Based on the your comments here, and (many) trials, I finally I have a working French-Canadian keyboard layout in ibus :D

I am inexperienced with keyboard configuration. Any modification I tried in /etc/sysconfig/keyboard, or by generating a xorg file, have failed.

However removing the setxkbmap command in /etc/xdg/lxsession/LXDE/autostart and re-configuring the ibus advanced preferences did it on re-booting.

You were correct, it was a user configuration conflicting with ibus. Thank you again for the follow up. From now on, I only rely on ibus to change input language.
Comment 25 fujiwara 2011-11-08 05:43:00 EST
The right Alt is used as AltGR so you could use another keybinding to switch layouts except for right Alt.
As I noted, you could simply replace grp:rctrl_rshift_toggle with grp:lctrl_lshift_toggle in /etc/xdg/lxsession/LXDE/autostart .

Note You need to log in before you can comment on or make changes to this bug.