Bug 74223 - Kernel panic on boot
Kernel panic on boot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-18 01:47 EDT by Bill McCarty
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-18 12:49:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill McCarty 2002-09-18 01:47:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; Q312461)

Description of problem:
Running up2date on working host installed kernel-2.4.9-34. This kernel panics 
on boot, with the following messages:

 "kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno = 13
  VFS: Cannot open root device "sda2" or 08:02
  Please append a correct "root=" boot option"

However, grub.conf shows same configuration for 2.4.9-34 as that for previous 
kernel, 2.4.9-21:

     10 default=0
     11 timeout=10
     12 splashimage=(hd0,0)/grub/splash.xpm.gz
     13 title Red Hat Linux (2.4.9-34)
     14         root (hd0,0)
     15         kernel /vmlinuz-2.4.9-34 ro root=/dev/sda2
     16         initrd /initrd-2.4.9-34.img
     17 title Red Hat Linux (2.4.9-21)
     18         root (hd0,0)
     19         kernel /vmlinuz-2.4.9-21 ro root=/dev/sda2
     20         initrd /initrd-2.4.9-21.img


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot system
2. Observe kernel panic
	

Actual Results:  Kernel panic, with messages shown above.

Expected Results:  System should boot okay.

Additional info:

Classified as having severity of Security, since kernel-2.4.9-31 fixed security 
issues. Up2date skips 2.4.9-31 in favor of newer 2.4.9-34, which panics. 
Therefore, unable to use up2date to correctly install kernel affording fixes 
associated with 2.4.9-31.
Comment 1 Arjan van de Ven 2002-09-18 04:23:46 EDT
what kind of scsi controller do you have ?
(is it a dell aacraid ?)
Comment 2 Bill McCarty 2002-09-18 08:42:07 EDT
No, it's a BusLogic BT-958.
Comment 3 Bill McCarty 2002-09-24 01:32:30 EDT
Fixed by running mkinitrd /boot/initrd-2.4.9-34 2.4.9-34
Comment 4 Alan Cox 2002-12-18 12:49:09 EST
Newer stuff fixes the mkinitd bug

Note You need to log in before you can comment on or make changes to this bug.