Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 742344 - [nouveau] Resume from suspend is broken
[nouveau] Resume from suspend is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-29 15:26 EDT by Jaroslav Škarvada
Modified: 2012-04-18 15:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:48:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (62.99 KB, text/plain)
2011-09-29 15:31 EDT, Jaroslav Škarvada
no flags Details

  None (edit)
Description Jaroslav Škarvada 2011-09-29 15:26:24 EDT
Description of problem:
On F16, GeForce 8800 GT, video is not reinitialized after resume from STR, everything other works, only reboot helps to get the video back. It is correctly initalized after resume from hibernate. Maybe it is related to bug 697315.

Version-Release number of selected component (if applicable):
3.1.0-0.rc6.git0.3.fc16.i686

How reproducible:
Always

Steps to Reproduce:
1. pm-suspend
2. resume
  
Actual results:
Video is not re-initialized.

Expected results:
Video is correctly re-initialized.
Comment 1 Jaroslav Škarvada 2011-09-29 15:31:18 EDT
Created attachment 525632 [details]
dmesg
Comment 2 Leif H. Asgeirsson 2012-01-13 13:22:16 EST
I had the same bug with a GeForce 9100M card on x86_64. The problem disappeared after I disabled nouveau and installed the NVIDIA drivers with rpmfusion's kmod-nvidia package. Could this be a bug in nouveau?
Comment 3 Jaroslav Škarvada 2012-01-17 09:52:09 EST
(In reply to comment #2)
> I had the same bug with a GeForce 9100M card on x86_64. The problem disappeared
> after I disabled nouveau and installed the NVIDIA drivers with rpmfusion's
> kmod-nvidia package. Could this be a bug in nouveau?

It seems so. This is probably dupe of bug 697315. There is also (maybe related) upstream bugzilla:
https://bugs.freedesktop.org/show_bug.cgi?id=40572
Comment 4 Dave Jones 2012-03-22 12:44:56 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Dave Jones 2012-03-22 12:49:18 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 6 Dave Jones 2012-03-22 12:58:48 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 7 Jaroslav Škarvada 2012-04-18 15:09:40 EDT
Hi Dave, thanks, currently I am unable to easily re-test with F16, but I tested with F17 during F17 PM test day and eveything works great, thus I think we could close this.
Comment 8 Jaroslav Škarvada 2012-04-18 15:10:55 EDT
Kernel 3.3.0-1.fc17.x86_64 thus it would be probably the same on f16,
Comment 9 Josh Boyer 2012-04-18 15:48:36 EDT
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.