Bug 74256 - keyspan.o kernel module is missing firmware for Keyspan USA-49W
keyspan.o kernel module is missing firmware for Keyspan USA-49W
Status: CLOSED DUPLICATE of bug 76473
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-18 15:33 EDT by Tom Wood
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-18 16:53:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Portion of /var/log/messages (5.90 KB, text/plain)
2002-09-18 15:36 EDT, Tom Wood
no flags Details
ksymoops from the previously attached /var/log/messages segment (5.70 KB, text/plain)
2002-09-18 15:38 EDT, Tom Wood
no flags Details
dmesg from boot with Keyspan USA-49W attached (11.23 KB, text/plain)
2002-09-20 11:31 EDT, Tom Wood
no flags Details
dmesg generated from plugging Keyspan USA-49W into a freshly booted machine (3.14 KB, text/plain)
2002-09-20 11:33 EDT, Tom Wood
no flags Details
oops of Keyspan USA49W with 2.4.18-17-7.x kernel (4.68 KB, text/plain)
2002-11-12 10:27 EST, Tom Wood
no flags Details

  None (edit)
Description Tom Wood 2002-09-18 15:33:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
The keyspan.o module seemingly wasn't compiled with support for the Keyspan USA-49W USB to 4-port serial adapter.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Plug in Keyspan USA-49W on USB bus.
2.  Watch the red LED *not* light, as the unit isn't downloaded the necessary firmware from the keyspan.o module.
3.  Be disappointed.
 

Actual Results:  The Keyspan USA-49W isn't loaded with its firmware, and so it sits idle.

Expected Results:  The red LED indicating downloading of firmware and its IPO should have lit, and it should be operational as /dev/ttyUSB[0-3]

Additional info:

I will attach a portion of /var/log/messages that occurs immediately after plugging in the Keyspan USA-49W.  The major downside of this is that the computer has to be rebooted to clear the "keyspan" from lsmod.  "rmmod keyspan" locks the shell - control-C will now break out.

I have attempted to recompile keyspan.o with the USA-49W firmware, with the same lack of success.
Comment 1 Tom Wood 2002-09-18 15:36:33 EDT
Created attachment 76548 [details]
Portion of /var/log/messages
Comment 2 Tom Wood 2002-09-18 15:38:07 EDT
Created attachment 76549 [details]
ksymoops from the previously attached /var/log/messages segment
Comment 3 Tom Wood 2002-09-19 15:52:25 EDT
 Note that by building a kernel from the standard i686 config 
file from the configs directory from the 
kernel-source-2.4.18-10.rpm, modified to include the firmware, 
keyspan.o fails to load firmware, can't be removed with rmmod 
(shell hangs), and unplugging the Keyspan from the USB port 
oopses khubd (see attachments). 
 
Using the same kernel .config file as above, both the stock 
2.4.18 and 2.4.19 kernels behave properly.  Firmware is 
downloaded, rmmod functions properly, and there is no oops when 
unplugging the Keyspan from the USB bus.  Somehow, one or more 
of the -10 Red Hat kernel's tweaks/patches cause the above 
problem.
Comment 4 Pete Zaitcev 2002-09-20 01:43:08 EDT
Please attach the result of dmesg after the failure,
but do not edit it. The messages file is too confusing.
Comment 5 Tom Wood 2002-09-20 11:31:39 EDT
Created attachment 76725 [details]
dmesg from boot with Keyspan USA-49W attached
Comment 6 Tom Wood 2002-09-20 11:33:05 EDT
Created attachment 76726 [details]
dmesg generated from plugging Keyspan USA-49W into a freshly booted machine
Comment 7 Tom Wood 2002-09-20 11:38:13 EDT
Attachment id=76725 is the dmesg from the boot of this machine with the Keyspan
attached before booting.  Attachment id=76726 is from the same machine, after
rebooting without having the Keyspan attached, logging in as root, and plugging
in the Keyspan to the USB port.
Comment 8 Tom Wood 2002-10-03 12:53:27 EDT
keyspan works properly with stock 2.4.19 and 2.4.20-pre8 kernels running on Psyche.
Comment 9 Tom Wood 2002-11-12 10:26:05 EST
2.4.18-17.7.x on 7.3 oopses as well.  I will attach a ksymoops trace from a
custom kernel built with the USA49W firmware included, using
/usr/src/linux-2.4.18-17.7.x/configs/kernel-2.4.18-athlon.config as the base,
changing only the USA49W firmware line.

At a cold boot, with the Keyspan also cold booted (no firmware loaded into the
Keyspan at this point), the kernel oopses at boot.  But if I now reboot the
linux box, the Keyspan will be fed its firmware and will work until it is
unplugged.  Upon replugging the Keyspan, the kernel will oops again.
Comment 10 Tom Wood 2002-11-12 10:27:47 EST
Created attachment 84645 [details]
oops of Keyspan USA49W with 2.4.18-17-7.x kernel
Comment 11 Tom Wood 2002-11-18 16:53:34 EST
2.4.18-18.8.0 doesn't work either.  Same problems.
Comment 12 Pete Zaitcev 2002-11-26 18:07:09 EST

*** This bug has been marked as a duplicate of 76473 ***

Note You need to log in before you can comment on or make changes to this bug.