Bug 742593 - add module alias rpc_pipefs -> sunrpc
add module alias rpc_pipefs -> sunrpc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 13:01 EDT by Jeff Layton
Modified: 2011-11-17 08:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-17 08:17:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2011-09-30 13:01:12 EDT
I noticed on my rawhide VM that rpc.idmapd was almost never getting started at boot time.

The problem seems to be that systemd was trying to start it very early in the boot process, before any of the other nfs services were started, and sunrpc.ko was not plugged in yet.

When this happens, rpc_pipefs has not been registered as a filesystem yet so the mount attempt of it fails. I was able to fix this by adding /etc/modprobe.d/sunrpc.conf with the following contents:

alias rpc_pipefs sunrpc

...with that, the nfs-idmap service seems to start correctly. I suggest that we ship a similar file as part of nfs-utils for now.

There's an upstream patch to add this alias internally to the sunrpc module, that Bruce is going to push for 3.2. That should eventually make this file unnecessary but it should be harmless even with that in place.
Comment 1 Jeff Layton 2011-09-30 13:09:36 EDT
cc'ing JCM...

John, does this look like the right thing to do for now?
Comment 2 Steve Dickson 2011-11-17 08:17:33 EST
The "alias rpc_pipefs sunrpc" now exists in /etc/modprobe.d/dist.conf

Note You need to log in before you can comment on or make changes to this bug.