Bug 74263 - /bin/unicode_start damages keymaps
/bin/unicode_start damages keymaps
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: kbd (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-18 17:12 EDT by Miloslav Trmac
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-20 06:26:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmac 2002-09-18 17:12:35 EDT
Version: kbd-1.06-24, or the (null) one

The
dumpkeys | loadkeys --unicode
line in /bin/unicode_start damages keymaps, because there is apparently no
way to get the needed information about encoding of the original keymap.

To reproduce:
1. Use kbdconfig to set keyboard to Czech (keymap name cz-lat2)
2. Login on console, press AltGr-2 (or 3, 4, 5, 6)
3. run 'loadkeys /lib/kbd/keymaps/i386/qwerty/cz-lat2.kmap.gz'
4. press the same keys again.

The result is wrong in 2., but right in 4. I.e. pressing AltGr-2, 3, 4, 5, 6
produces "latin small {e, s, c, r, z} with caron", respectively.
Comment 1 Miloslav Trmac 2002-09-18 17:22:49 EDT
The trouble is that dumpkeys uses by default charset iso-8859-1 when
dumping the keys, but the original keymap is in iso-8859-2. The charset
information from the original keymap used by loadkeys has not been stored
anywhere, so dumpkeys has no way to obtain it. I'm not sure this can
be fixed nicely.

A possible workaround for RHL has been sugested as #74264.
Comment 2 Miloslav Trmac 2002-09-21 14:29:09 EDT
Sorry, I am typing this in my Valhalla box, so the steps to reproduce
were completely wrong )-:
Next try:
To reproduce:
1. Use kbdconfig to set keyboard to Czech (keymap name cz-lat2)
2. Login on console, press AltGr-2 (or 3, 4, 5, 6)
   (result is OK)
3. reboot
4. Login on console, press the same keys again (result is bad)
3. run 'loadkeys --unicode cz-lat2'
4. press the same keys again. (result is OK).


Note You need to log in before you can comment on or make changes to this bug.