Bug 742636 - gnome3 - conflict with sugar-desktop installed telepathy
Summary: gnome3 - conflict with sugar-desktop installed telepathy
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-salut
Version: 16
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedNTH
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-30 20:38 UTC by satellitgo
Modified: 2011-11-03 09:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-03 09:38:05 UTC
Type: ---


Attachments (Terms of Use)

Description satellitgo 2011-09-30 20:38:24 UTC
Description of problem:
adamw: possible future NTH ?: a conflict with sugar-desktop installed telepathy ;  gnome3-shell has pop up which asks for password. looks like sugar jabber connection is interfered with when logged in to sugar on gdm?  


Version-Release number of selected component (if applicable):
gnome3-shell 3.1.92
sugar-desktop 0.93.4


How reproducible:
log in to sugar on gdm
gnome3-shell pop up appears asking for password
jabber.sugarlabs.org connection does not connect.


Steps to Reproduce:
1.yum groupinstall sugar-desktop in f16 RC4 Beta HD install
2.logout from gnome3-shell
3.login: (session *sugar on gdm)
  
Actual results:
gnome3-shell pop up appears asking for password

Expected results:
no pop up
jabber.sugarlabs.org would connect.

This may involve the integration of Network-manager in sugar-desktop
https://bugzilla.redhat.com/show_bug.cgi?id=697649


Additional info:
related bug?: http://bugs.sugarlabs.org/ticket/3100#comment:1

Comment 1 satellitgo 2011-10-01 01:09:53 UTC
(In reply to comment #0) updated 09/30/2011
> Description of problem:
> adamw: possible future NTH ?: a conflict with sugar-desktop installed telepathy
> ;  gnome3-shell has pop up which asks for password. looks like sugar jabber
> connection is interfered with when logged in to sugar on gdm?  
> 
> 
> Version-Release number of selected component (if applicable):
> gnome3-shell 3.1.92
requires 2 x Oh-No! logout to get to gnome3-shell
> sugar-desktop 0.93.4
> 
> 
> How reproducible:
> log in to sugar on gdm
> gnome3-shell pop up appears asking for password
> jabber.sugarlabs.org connection does not connect.
> 
> 
> Steps to Reproduce:
> 1.yum groupinstall sugar-desktop in f16 RC3 Beta netinstall install to  HD
> 2.logout from gnome3-shell
> 3.login: (session *sugar on gdm)
> 
> Actual results:
(both wired and wireless are off when booted)
> gnome3-shell pop up appears:
"Connection to Jabber Failed"
  (Reconnect) (Edit Account) 
> 
> Expected results:
> no pop up
> jabber.sugarlabs.org would connect.
> 
> This may involve the integration of Network-manager in sugar-desktop
> https://bugzilla.redhat.com/show_bug.cgi?id=697649
> 
> 
> Additional info:
> related bug?: http://bugs.sugarlabs.org/ticket/3100#comment:1
Software Update
145 updates (09/30/2011)

Comment 2 satellitgo 2011-10-01 01:45:03 UTC
(In reply to comment #1)
> (In reply to comment #0) updated 09/30/2011
> > Description of problem:
> > adamw: possible future NTH ?: a conflict with sugar-desktop installed telepathy
> > ;  gnome3-shell has pop up which asks for password. looks like sugar jabber
> > connection is interfered with when logged in to sugar on gdm?  
> > 
> > 
> > Version-Release number of selected component (if applicable):
> > gnome3-shell 3.1.92
> requires 2 x Oh-No! logout to get to gnome3-shell
> > sugar-desktop 0.93.4
> > 
> > 
> > How reproducible:
> > log in to sugar on gdm
> > gnome3-shell pop up appears asking for password
> > jabber.sugarlabs.org connection does not connect.
> > 
> > 
> > Steps to Reproduce:
> > 1.yum groupinstall sugar-desktop in f16 RC3 Beta netinstall install to  HD
> > 2.logout from gnome3-shell
> > 3.login: (session *sugar on gdm)
> > 
> > Actual results:
> (both wired and wireless are off when booted)
> > gnome3-shell pop up appears:
> "Connection to Jabber Failed"
>   (Reconnect) (Edit Account) 
> > 
> > Expected results:
> > no pop up
> > jabber.sugarlabs.org would connect.
> > 
> > This may involve the integration of Network-manager in sugar-desktop
> > https://bugzilla.redhat.com/show_bug.cgi?id=697649
> > 
> > 
> > Additional info:
> > related bug?: http://bugs.sugarlabs.org/ticket/3100#comment:1
> Software Update
> 145 updates (09/30/2011)
after updates message to log out (no mouse response to click)
 use tab and return (bug?)
gdm login to gnome 3.2.0 
terminal:
sugar-emulator -f:
sugar 0.94.0
no jabber connection or wireless AP's visible in f1 Network Neighborhood
System Settings/ Network wireless Unavailable It was there before running sugar-emulator....(BUG?)
Log Out: Oh no! gdm overwrites Oh-no screen
 gdm *sugar
Jabber shows avitars (ie it works) but  wireless AP not shown only Ad Hoc Icons
 Synopsis: 1)Jabber works only with wired connection and NOT in sugar-emulator
           2) sugar-emulator crashes Network-Manager wireless AP

Comment 3 Peter Robinson 2011-10-05 14:49:26 UTC
satellit: Please clarify the following:
1) Is it link-local communications that are at issue or connections to jabber.sugarlabs.org.
2) Is the error or issue your seeing when your logged into gnome or into sugar?

Comment 4 Adam Williamson 2011-10-07 19:47:42 UTC
Discussed at 2011-10-07 NTH review meeting. Agreed this is rejected as NTH as it requires both Sugar and GNOME to be installed, so it doesn't affect the live spin and for post-install cases can be fixed with an update.

Comment 5 Peter Robinson 2011-11-03 09:38:05 UTC
I've tried to reproduce this problem over a number of devices and can't


Note You need to log in before you can comment on or make changes to this bug.