This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 742717 - Cannot Enable or Disable Hangul Input Method with short key.
Cannot Enable or Disable Hangul Input Method with short key.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-01 22:23 EDT by sangu
Modified: 2011-10-24 01:00 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.4.0-5.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 00:16:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Shotcuts Enable, Disable Empty in ibus-setup. (44.94 KB, image/png)
2011-10-03 20:51 EDT, sangu
no flags Details

  None (edit)
Description sangu 2011-10-01 22:23:52 EDT
Description of problem:
Cannot Enable or Disable Hangul Input Methond with short key.

Version-Release number of selected component (if applicable):
1.4.0-3.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1. Launch gedit
2. Click Hangul Key or another short key (like ctrl+space)
3.
  
Actual results:


Expected results:


Additional info:
ibus-hangul-1.3.1-7.fc16.x86_64
Comment 1 fujiwara 2011-10-03 02:13:13 EDT
I cannot reproduce your problem.

How about setting GTK_IM_MODULE=ibus ?
% env GTK_IM_MODULE=ibus gedit

How about other IM engines likes ibus-anthy or ibus-rawcode?
Comment 2 sangu 2011-10-03 20:51:10 EDT
Created attachment 526156 [details]
Shotcuts Enable, Disable Empty in ibus-setup.

(In reply to comment #1)
> I cannot reproduce your problem.
> 
> How about setting GTK_IM_MODULE=ibus ?
> % env GTK_IM_MODULE=ibus gedit
No Change.

> How about other IM engines likes ibus-anthy or ibus-rawcode?
After adding  anthy in ibus-setup, ctrl+space works well in hangul input method.
Then, still No Change with Hangul Key.
Comment 3 sangu 2011-10-03 20:55:55 EDT
> > How about other IM engines likes ibus-anthy or ibus-rawcode?
> After adding  anthy in ibus-setup, ctrl+space works well in hangul input
> method.
Additional info:
After trying to enable anthy input method, ctrl+space work in hangul input method.

> Then, still No Change with Hangul Key.
Comment 4 fujiwara 2011-10-03 21:40:37 EDT
(In reply to comment #3)
> > > How about other IM engines likes ibus-anthy or ibus-rawcode?
> > After adding  anthy in ibus-setup, ctrl+space works well in hangul input
> > method.
> Additional info:
> After trying to enable anthy input method, ctrl+space work in hangul input
> method.
> 
> > Then, still No Change with Hangul Key.

Hmm.., strange.
Do you really have the Hangul key but not right alt key?

% grep Hangul /usr/share/ibus/component/hangul.xml
			<hotkeys>Control+space,Hangul</hotkeys>

The latest ibus-hangul enables itself by Control+space and Hangul.
It works with a Korean keyboard but not an US keyboard.

You could check with 'xev' command if you have Hangul key:

% xev
KeyPress event, serial 29, synthetic NO, window 0xbc00001,
    root 0x131, subw 0x0, time 660866977, (603,119), root:(604,529),
    state 0x0, keycode 108 (keysym 0xff31, Hangul), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

If you have the Hangul key, could you check if your problem can be reproduced with a new user account instead of the current user account?
Comment 5 fujiwara 2011-10-05 21:37:07 EDT
Any update?
Comment 6 sangu 2011-10-07 09:03:59 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > > > How about other IM engines likes ibus-anthy or ibus-rawcode?
> > > After adding  anthy in ibus-setup, ctrl+space works well in hangul input
> > > method.
> > Additional info:
> > After trying to enable anthy input method, ctrl+space work in hangul input
> > method.
> > 
> > > Then, still No Change with Hangul Key.
> 
> Hmm.., strange.
> Do you really have the Hangul key but not right alt key?
> 
> % grep Hangul /usr/share/ibus/component/hangul.xml
>    <hotkeys>Control+space,Hangul</hotkeys>

$ grep Hangul /usr/share/ibus/component/hangul.xml
	<name>org.freedesktop.IBus.Hangul</name>
			<hotkeys>Control+space,Hangul</hotkeys>

> The latest ibus-hangul enables itself by Control+space and Hangul.
> It works with a Korean keyboard but not an US keyboard.
> 
> You could check with 'xev' command if you have Hangul key:
> 
> % xev
> KeyPress event, serial 29, synthetic NO, window 0xbc00001,
>     root 0x131, subw 0x0, time 660866977, (603,119), root:(604,529),
>     state 0x0, keycode 108 (keysym 0xff31, Hangul), same_screen YES,
>     XLookupString gives 0 bytes: 
>     XmbLookupString gives 0 bytes: 
>     XFilterEvent returns: False
> 
> If you have the Hangul key, could you check if your problem can be reproduced
> with a new user account instead of the current user account?
$ xev
KeyRelease event, serial 32, synthetic NO, window 0x2800001,
    root 0x15a, subw 0x0, time 46594848, (160,-15), root:(1897,60),
    state 0x0, keycode 130 (keysym 0xff31, Hangul), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
Comment 7 Jaekyun Lee 2011-10-07 09:18:24 EDT
I have same problem on Rawhide


I also can't switch between hangul and English by toggle key, 
but, when i press 'next input method' key(default is alt+L_shift) two times, then toggle key works


version information:

ibus-1.4.0-3.fc17.x86_64
ibus-hangul-1.3.1-7.fc17.x86_64
Comment 8 fujiwara 2011-10-12 04:59:53 EDT
(In reply to comment #6)
> $ xev
> KeyRelease event, serial 32, synthetic NO, window 0x2800001,
>     root 0x15a, subw 0x0, time 46594848, (160,-15), root:(1897,60),
>     state 0x0, keycode 130 (keysym 0xff31, Hangul), same_screen YES,
>     XLookupString gives 0 bytes: 
>     XFilterEvent returns: False

It seems the Hangul is assigned correctly.

I added debug codes in ibus-daemon:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3424949

Could you replace your ibus-1.4.0-3.fc16.x86_64.rpm with the debug one?
And I'd like to know the output of ibus-daemon when you type Hangul key.

1. Right click on ibus panel icon and choose 'Quit'.
2. Replace the ibus-daemon with the debug one.
3. Run ibus-daemon by manual:
% ibus-daemon --xim --verbose
4. Run gedit
5. Type Hangul key on gedit text buffer.

I'd like to get all the log about '_add_engine_hotkey_with_hotkeys' and 'bus_ibus_impl_filter_keyboard_shortcuts'.
Thanks.
Comment 9 Hajime Taira 2011-10-14 03:09:28 EDT
I have same problem in Japanese environment on Fedora 16 beta.
I can't toggle ibus. Hot-key is "Control+Space".
Comment 10 fujiwara 2011-10-14 03:51:11 EDT
(In reply to comment #9)
> I have same problem in Japanese environment on Fedora 16 beta.
> I can't toggle ibus. Hot-key is "Control+Space".

This issue is not "Control+Space".
Comment 11 Jaekyun Lee 2011-10-14 08:21:32 EDT
it doesn't look key code problem. 
because, it happens any key code set as toggle key 
(i'm using Shift+spacne and hanul key as toggle key)

but, I think this is initialize problem of 'toogle key'
To using toggle key, I need to change to next input method once at least.
after input method is changed,  toggle key works fine.
Comment 12 fujiwara 2011-10-17 03:08:27 EDT
(In reply to comment #11)
> it doesn't look key code problem. 
> because, it happens any key code set as toggle key 

It seems your problem is different from this. A new bug would be good for you.
Comment 13 fujiwara 2011-10-21 03:48:37 EDT
sangu:

It seems the scratch-build was removed due to the time out.
Recently one bug 746869 is fixed.
It would be good if you could test ibus-1.4.0-4.fc16 for the Hangul key.
If your problem is not fixed with it, I will create the same scratch-build again.

(In reply to comment #8)
> (In reply to comment #6)
> > $ xev
> > KeyRelease event, serial 32, synthetic NO, window 0x2800001,
> >     root 0x15a, subw 0x0, time 46594848, (160,-15), root:(1897,60),
> >     state 0x0, keycode 130 (keysym 0xff31, Hangul), same_screen YES,
> >     XLookupString gives 0 bytes: 
> >     XFilterEvent returns: False
> 
> It seems the Hangul is assigned correctly.
> 
> I added debug codes in ibus-daemon:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3424949
> 
> Could you replace your ibus-1.4.0-3.fc16.x86_64.rpm with the debug one?
> And I'd like to know the output of ibus-daemon when you type Hangul key.
> 
> 1. Right click on ibus panel icon and choose 'Quit'.
> 2. Replace the ibus-daemon with the debug one.
> 3. Run ibus-daemon by manual:
> % ibus-daemon --xim --verbose
> 4. Run gedit
> 5. Type Hangul key on gedit text buffer.
> 
> I'd like to get all the log about '_add_engine_hotkey_with_hotkeys' and
> 'bus_ibus_impl_filter_keyboard_shortcuts'.
> Thanks.
Comment 14 sangu 2011-10-24 00:16:55 EDT
Fixed in 1.4.0-5.fc16.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.