Bug 742753 - Resize locks X cursor with twm window manager
Resize locks X cursor with twm window manager
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-02 09:32 EDT by Zdenek Kabelac
Modified: 2012-01-11 22:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-11 22:06:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2011-10-02 09:32:46 EDT
Description of problem:

Since there are times when Rawhide requires to use non-gnome-shell window manager twm is a natural choice. Problem with gnome-terminal is - whenever resize lower right corner is touched - it'll not work with twm (it has it's own mechanism) - but the problem is - it keeps the windows focus locked for cursor - so this looks like X queue processing bug in gnome-terminal.

Version-Release number of selected component (if applicable):
gnome-terminal-3.2.0-1.fc17.x86_64

How reproducible:


Steps to Reproduce:
1. Start X with twm window manager
2. Open gnome-terminal and try to resize with lower right corner.
3.  
  
Actual results:
X cursor stays locked with focus on gnome-terminal window forever and requires session restart.

Expected results:


Additional info:
Comment 1 Fedora Admin XMLRPC Client 2012-01-10 10:49:10 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2012-01-10 10:50:58 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Matthias Clasen 2012-01-11 22:06:20 EST
I've fixed this recently in gtk.

Note You need to log in before you can comment on or make changes to this bug.