Bug 742756 - RFE: Please make use of xen optional / put xen bits in a subpackage
RFE: Please make use of xen optional / put xen bits in a subpackage
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-02 10:05 EDT by Hans de Goede
Modified: 2012-06-07 15:22 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 15:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2011-10-02 10:05:23 EDT
I noticed that I had xen-libs installed all of a sudden, doing rpm -e pointed out that libvirt now a days requires xen-libs, would it be possible to put the xen support in a separate subpackage and have that require xen-libs?
Comment 1 Daniel Berrange 2011-10-03 04:49:47 EDT
It isn't really practical to separate out the Xen dep into a sub-RPM, since it is all part of the same binary. 

While we do have an optional to build libvirt drivers as dlopen'able modules, this is currently broken in a number of scenarios, so we cannot enable it.

Since the size of the 'xen-libs' package is pretty small, and there's not particular functional downside to having it present, figuring out a way to fix this has not been an important priority.
Comment 2 Fedora Admin XMLRPC Client 2011-11-30 14:32:30 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2011-11-30 14:36:02 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-11-30 14:43:20 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-11-30 14:53:49 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Cole Robinson 2012-06-07 15:22:21 EDT
We are building separate modules on f17 and rawhide now. But not really worth the spec refactoring and churn for F16, so closing.

Note You need to log in before you can comment on or make changes to this bug.