Bug 74294 - Sep 19 00:34:48 reddog kernel: Assertion failure in do_get_write_access() at tra nsaction.c:709: "handle->h_buffer_credits > 0"
Sep 19 00:34:48 reddog kernel: Assertion failure in do_get_write_access() at ...
Status: CLOSED DUPLICATE of bug 52378
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-19 15:24 EDT by Mike Gahagan
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-15 07:34:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Gahagan 2002-09-19 15:24:16 EDT
Description of Problem:

Kernel BUG reported in 2.4.9-31

Version-Release number of selected component (if applicable):
2.4.9-31

How Reproducible:

Twice in one day, getting more info.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
	
Sep 19 00:34:48 reddog kernel: Assertion failure in do_get_write_access() at
transaction.c:709: "handle->h_buffer_credits > 0"
Sep 19 00:34:49 reddog kernel: ------------[ cut here ]------------
Sep 19 00:34:49 reddog kernel: kernel BUG at transaction.c:709!
Sep 19 00:34:49 reddog kernel: invalid operand: 0000
Sep 19 00:34:49 reddog kernel: Kernel 2.4.9-31
Sep 19 00:34:49 reddog kernel: CPU:    0
Sep 19 00:34:49 reddog kernel: EIP:   
0010:[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-369524/96]
 
  Not tainted
Sep 19 00:34:49 reddog kernel: EIP:    0010:[<c883dc8c>]    Not tainted
Sep 19 00:34:49 reddog kernel: EFLAGS: 00010282
Sep 19 00:34:49 reddog kernel: EIP is at journal_unlock_updates_Rf70b0954 [jbd]
0x510 
Sep 19 00:34:49 reddog kernel: eax: 00000021   ebx: 00000000   ecx: 00000001  
edx: 000026b7
Sep 19 00:34:49 reddog kernel: esi: c7958000   edi: 00000000   ebp: c7958000  
esp: c06afda4
Sep 19 00:34:49 reddog kernel: ds: 0018   es: 0018   ss: 0018
Sep 19 00:34:49 reddog kernel: Process dtterm (pid: 4147, stackpage=c06af000)
Sep 19 00:34:49 reddog kernel: Stack: c88459f0 000002c5 00000000 00000000
c0054b90 c7958094 c7958000 c51d4800 
Sep 19 00:34:49 reddog kernel:        c7b01810 c883ddd5 c51d4800 c7b01810
00000000 00000000 c16eac00 c51d4800 
Sep 19 00:34:49 reddog kernel:        c3aa4aa0 c884ef37 c51d4800 c79696f0
00000000 c883d276 c7958000 c51d4800 
Sep 19 00:34:49 reddog kernel: Call Trace:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-337424/96] __
insmod_jbd_S.rodata_L96 [jbd] 0x2370 
Sep 19 00:34:49 reddog kernel: Call Trace: [<c88459f0>]
__insmod_jbd_S.rodata_L96 [jbd] 0x2370 
Sep 19 00:34:49 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-369195/96]
journal_get_wr
ite_access_R9c73193f [jbd] 0x35 
Sep 19 00:34:49 reddog kernel: [<c883ddd5>] journal_get_write_access_R9c73193f
[jbd] 0x35 
Sep 19 00:34:49 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-299209/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x6ed7 
Sep 19 00:34:49 reddog kernel: [<c884ef37>] __insmod_ext3_S.text_L40936 [ext3]
0x6ed7 
Sep 19 00:34:49 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-372106/96]
__insmod_jbd_S
.text_L25348 [jbd] 0x216 
Sep 19 00:34:49 reddog kernel: [<c883d276>] __insmod_jbd_S.text_L25348 [jbd] 0x216 
Sep 19 00:34:49 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-371861/96]
journal_start_
R819d0567 [jbd] 0xb7 
Sep 19 00:34:49 reddog kernel: [<c883d36b>] journal_start_R819d0567 [jbd] 0xb7 
Sep 19 00:34:49 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-308495/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x4a91 
Sep 19 00:34:49 reddog kernel: [<c884caf1>] __insmod_ext3_S.text_L40936 [ext3]
0x4a91 
Sep 19 00:34:49 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-308472/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x4aa8 
Sep 19 00:34:49 reddog kernel: [<c884cb08>] __insmod_ext3_S.text_L40936 [ext3]
0x4aa8 
Sep 19 00:34:49 reddog kernel: [truncate_list_pages+337/352] truncate_list_pages
[kernel] 0x151 
Sep 19 00:34:49 reddog kernel: [<c0124821>] truncate_list_pages [kernel] 0x151 
Sep 19 00:34:49 reddog kernel: [truncate_inode_pages+119/136]
truncate_inode_pages [kernel] 0x77 
Sep 19 00:34:49 reddog kernel: [<c01248a7>] truncate_inode_pages [kernel] 0x77 
Sep 19 00:34:49 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-308692/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x49cc 
Sep 19 00:34:49 reddog kernel: [<c884ca2c>] __insmod_ext3_S.text_L40936 [ext3]
0x49cc 
Sep 19 00:34:49 reddog kernel: [vmtruncate+357/380] vmtruncate [kernel] 0x165 
Sep 19 00:34:49 reddog kernel: [<c01229bd>] vmtruncate [kernel] 0x165 
Sep 19 00:34:49 reddog kernel: [generic_file_write+1501/1520] generic_file_write
[kernel] 0x5dd 
Sep 19 00:34:49 reddog kernel: [<c012764d>] generic_file_write [kernel] 0x5dd 
Sep 19 00:34:49 reddog kernel: [update_process_times+30/140]
update_process_times [kernel] 0x1e 
Sep 19 00:34:49 reddog kernel: [<c011c26a>] update_process_times [kernel] 0x1e 
Sep 19 00:34:49 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-321333/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x186b 
Sep 19 00:34:49 reddog kernel: [<c88498cb>] __insmod_ext3_S.text_L40936 [ext3]
0x186b 
Sep 19 00:34:49 reddog kernel: [sys_write+149/244] sys_write [kernel] 0x95 
Sep 19 00:34:49 reddog kernel: [<c0131ed5>] sys_write [kernel] 0x95 
Sep 19 00:34:49 reddog kernel: [system_call+51/56] system_call [kernel] 0x33 
Sep 19 00:34:49 reddog kernel: [<c0106e0f>] system_call [kernel] 0x33 
Sep 19 00:34:49 reddog kernel: 
Sep 19 00:34:49 reddog kernel: 
Sep 19 00:34:49 reddog kernel: Code: 0f 0b 5a 59 8b 4c 24 20 8b 41 04 48 8b 54
24 20 89 42 04 8b
Comment 1 Mike Gahagan 2002-09-19 15:27:38 EDT
OOPS on a subsequent reboot, this is /home and reads as full even though it is
not... looks like fs corruption and this Oops occured right after mounting the FS.

Sep 19 14:42:59 reddog kernel: EXT3 FS 2.4-0.9.11, 3 Oct 2001 on sd(8,3),
internal journal
Sep 19 14:42:59 reddog kernel: EXT3-fs: mounted filesystem with ordered data mode.
Sep 19 14:45:38 reddog kernel: Unable to handle kernel NULL pointer dereference
at virtual address 00000018
Sep 19 14:45:38 reddog kernel:  printing eip:
Sep 19 14:45:38 reddog kernel: c88430bf
Sep 19 14:45:38 reddog kernel: *pde = 00000000
Sep 19 14:45:38 reddog kernel: Oops: 0000
Sep 19 14:45:38 reddog kernel: Kernel 2.4.9-31
Sep 19 14:45:38 reddog kernel: CPU:    0
Sep 19 14:45:38 reddog kernel: EIP:   
0010:[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-347969/96]
 
  Not tainted
Sep 19 14:45:38 reddog kernel: EIP:    0010:[<c88430bf>]    Not tainted
Sep 19 14:45:38 reddog kernel: EFLAGS: 00010282
Sep 19 14:45:38 reddog kernel: EIP is at journal_blocks_per_page_R338b3e60 [jbd]
0x20f 
Sep 19 14:45:38 reddog kernel: eax: c6b682a0   ebx: c65e9420   ecx: c711c094  
edx: c711c000
Sep 19 14:45:38 reddog kernel: esi: 00000000   edi: c6697880   ebp: c65e9420  
esp: c41d5d74
Sep 19 14:45:38 reddog kernel: ds: 0018   es: 0018   ss: 0018
Sep 19 14:45:38 reddog kernel: Process rm (pid: 2261, stackpage=c41d5000)
Sep 19 14:45:38 reddog kernel: Stack: c65e9420 c711c000 c6697880 c883ddb5
00000000 c65e9420 00000000 c6697880 
Sep 19 14:45:38 reddog kernel:        c65e9420 c884c633 c6697880 00000000
00001000 08038680 00000000 00000803 
Sep 19 14:45:38 reddog kernel:        00000290 c884d4ac c884d507 00000000
00000000 00000000 00000000 00000000 
Sep 19 14:45:38 reddog kernel: Call Trace:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-369227/96] jo
urnal_get_write_access_R9c73193f [jbd] 0x15 
Sep 19 14:45:38 reddog kernel: Call Trace: [<c883ddb5>]
journal_get_write_access_R9c73193f [jbd] 0x15 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-309709/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x45d3 
Sep 19 14:45:38 reddog kernel: [<c884c633>] __insmod_ext3_S.text_L40936 [ext3]
0x45d3 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-306004/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x544c 
Sep 19 14:45:38 reddog kernel: [<c884d4ac>] __insmod_ext3_S.text_L40936 [ext3]
0x544c 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-305913/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x54a7 
Sep 19 14:45:38 reddog kernel: [<c884d507>] __insmod_ext3_S.text_L40936 [ext3]
0x54a7 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-313537/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x36df 
Sep 19 14:45:38 reddog kernel: [<c884b73f>] __insmod_ext3_S.text_L40936[ext3]
0x36df 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-309333/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x474b 
Sep 19 14:45:38 reddog kernel: [<c884c7ab>] __insmod_ext3_S.text_L40936 [ext3]
0x474b 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-369278/96]
journal_unlock
_updates_Rf70b0954 [jbd] 0x606 
Sep 19 14:45:38 reddog kernel: [<c883dd82>] journal_unlock_updates_Rf70b0954
[jbd] 0x606 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-308396/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x4af4 
Sep 19 14:45:38 reddog kernel: [<c884cb54>] __insmod_ext3_S.text_L40936 [ext3]
0x4af4 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-372106/96]
__insmod_jbd_S
.text_L25348 [jbd] 0x216 
Sep 19 14:45:38 reddog kernel: [<c883d276>] __insmod_jbd_S.text_L25348 [jbd] 0x216 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-371861/96]
journal_start_
R819d0567 [jbd] 0xb7 
Sep 19 14:45:38 reddog kernel: [<c883d36b>] journal_start_R819d0567 [jbd] 0xb7 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-316730/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x2a66 
Sep 19 14:45:38 reddog kernel: [<c884aac6>] __insmod_ext3_S.text_L40936 [ext3]
0x2a66 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-316412/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x2ba4 
Sep 19 14:45:38 reddog kernel: [<c884ac04>] __insmod_ext3_S.text_L40936 [ext3]
0x2ba4 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-366697/96]
journal_stop_R
f3b2ff6c [jbd] 0x1ab 
Sep 19 14:45:38 reddog kernel: [<c883e797>] journal_stop_Rf3b2ff6c [jbd] 0x1ab 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-269024/96]
__insmod_ext3_
S.data_L672 [ext3] 0x200 
Sep 19 14:45:38 reddog kernel: [<c8856520>] __insmod_ext3_S.data_L672 [ext3] 0x200 
Sep 19 14:45:38 reddog kernel: [iput_free+246/460] iput_free [kernel] 0xf6 
Sep 19 14:45:38 reddog kernel: [<c0144afe>] iput_free [kernel] 0xf6 
Sep 19 14:45:38 reddog kernel:
[eepro100:__insmod_eepro100_O/lib/modules/2.4.9-31/kernel/drivers/net+-297510/96]
__insmod_ext3_
S.text_L40936 [ext3] 0x757a 
Sep 19 14:45:38 reddog kernel: [<c884f5da>] __insmod_ext3_S.text_L40936 [ext3]
0x757a 
Sep 19 14:45:38 reddog kernel: [d_delete+78/136] d_delete [kernel] 0x4e 
Sep 19 14:45:38 reddog kernel: [<c0142f06>] d_delete [kernel] 0x4e 
Sep 19 14:45:38 reddog kernel: [vfs_permission+120/276] vfs_permission [kernel]
0x78 
Sep 19 14:45:38 reddog kernel: [<c013a62c>] vfs_permission [kernel] 0x78 
Sep 19 14:45:38 reddog kernel: [vfs_unlink+341/392] vfs_unlink [kernel] 0x155 
Sep19 14:45:38 reddog kernel: [<c013c5b5>] vfs_unlink [kernel] 0x155 
Sep 19 14:45:38 reddog kernel: [lookup_hash+106/136] lookup_hash [kernel] 0x6a 
Sep 19 14:45:38 reddog kernel: [<c013b50a>] lookup_hash [kernel] 0x6a 
Sep 19 14:45:38 reddog kernel: [sys_unlink+150/256] sys_unlink [kernel] 0x96 
Sep 19 14:45:38 reddog kernel: [<c013c67e>] sys_unlink [kernel] 0x96 
Sep 19 14:45:38 reddog kernel: [system_call+51/56] system_call [kernel] 0x33 
Sep 19 14:45:38 reddog kernel: [<c0106e0f>] system_call [kernel] 0x33 
Sep 19 14:45:39 reddog kernel: 
Sep 19 14:45:39 reddog kernel: 
Sep 19 14:45:39 reddog kernel: Code: f6 46 18 80 74 0b 8b 5e 40 e9 c0 00 00 00
8d 76 00 8b 46 10

..appears to have killed the machine.. no logs after this point.
Comment 2 Stephen Tweedie 2002-11-11 15:48:12 EST
Was this reproducible after a fsck?  Was there anything _before_ that second
oops in the logs?  The second oops is a sign that there was a badly-formed inode
in memory _before_ ext3 was called.  The first oops fits a pattern I've seen
before in which deleting an already-corrupt file causes problems, but I've not
been able to pin down the exact cause yet.
Comment 3 Stephen Tweedie 2002-11-15 07:34:23 EST
The oops is a duplicate of an existing bug.  The data corruption is
undiagnosable on this information, and is as likely to be a hardware problem as
software.
Comment 4 Stephen Tweedie 2002-11-15 07:34:56 EST

*** This bug has been marked as a duplicate of 52378 ***

Note You need to log in before you can comment on or make changes to this bug.