Bug 74331 - ^J shows up as ^M
Summary: ^J shows up as ^M
Status: CLOSED DUPLICATE of bug 72639
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-20 16:47 UTC by Piet E Barber
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Piet E Barber 2002-09-20 16:47:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
I have discovered that the terminal appears to interpret ^J as ^M. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start vi
2. type 'i' to insert text
3. type Ctrl V
4. type Ctrl J
5. Observe ^M
This does not happen with other versions of gnome-terminal
	
Actual Results:  I saw ^M instead of ^J

Expected Results:  I expected to see ^J instead of ^M.  This comes into play
when using pico to edit documents. ^J justifies a skewed paragraph.  Imagine my
amazement when it only inserted a newline. 

Additional info:

My keyboard set is standard US, I don't have any special languages or fonts
installed.  This is pretty much a run-of-the-mill null installation.

Comment 1 Barry K. Nathan 2002-09-21 07:56:56 UTC
What you're seeing is bug 72639, I think; I've changed the summary of that bug
to hopefully make it easier to find.

Interestingly enough, with vte-0.8.19, I'm seeing ^@ show up in vi at step 5.
I'm guessing that's a vim bug or feature (I don't even know which), as I don't
have this bug/feature in bash, this bug/feature also shows up at a text (non-X)
console, and ^J still works fine in pine and pico.

Comment 2 Nalin Dahyabhai 2003-01-14 04:32:14 UTC
Marking as a duplicate of 72639.

*** This bug has been marked as a duplicate of 72639 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:49:39 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.