Bug 74334 - font nightmare if ~/.gconfd has wrong perms
Summary: font nightmare if ~/.gconfd has wrong perms
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: GConf2   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-20 18:32 UTC by Mike McLean
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 23:59:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McLean 2002-09-20 18:32:52 UTC
* GConf2-1.2.1-3

Granted, you can say the user shouldn't alter the perms of ~/.gconfd, but it
doesn't seem like something that should cause this much of a problem (since
gconf is running as the user and can fix the perms if it wants).

Steps to reproduce:
1. while gconfd is not running, chmod 711 ~/.gconfd
2. log into gnome
3. Look at all the tiny fonts! (unreadably so)

Comment 1 Havoc Pennington 2002-09-20 19:16:20 UTC
I would tend to say "don't do that then," but leaving the 
bug open because I don't understand why this happens - 
the default font size should get picked up from 
the system gconf dir still.

Comment 2 Havoc Pennington 2002-12-19 23:59:50 UTC
I'm going to close this as I think it'll be fixed by font size/dpi sanity checks
in the configuration stuff or in pango. It'd be nice to investigate further 
but I doubt I'll ever have time.


Note You need to log in before you can comment on or make changes to this bug.