Bug 743389 - Can't upgrade from Fedora 15 to Fedora 16 Beta, using preupgrade
Can't upgrade from Fedora 15 to Fedora 16 Beta, using preupgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
15
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-04 14:34 EDT by Panormitis Petrou
Modified: 2011-10-10 08:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-05 14:56:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panormitis Petrou 2011-10-04 14:34:29 EDT
Description of problem:
Can't upgrade from Fedora 15 to Fedora 16 Beta, using preupgrade.
When trying to upgrade, preupgrade raises an "Cannot find a valid baseurl for repo: preupgrade" error.
After further investigation, it seems the file http://mirrors.fedoraproject.org/releases.txt has a wrong line:
The line: installmirrorlist=http://mirrors.fedoraproject.org/mirrorlist?pub/fedora/linux/development/16/$basearch/os/
Should be: installmirrorlist=http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/$basearch/os/

One temporary fix is to download the file releases.txt, edit the wrong line and use that file (releases.txt) with preupgrade.

Version-Release number of selected component (if applicable):
1.1.9-1.fc15

How reproducible:


Steps to Reproduce:
1. Open a terminal
2. su -
3. preupgrade
  
Actual results:
The upgrade can't proceed, an error "Cannot find a valid baseurl for repo: preupgrade" is displayed.

Expected results:
preupgrade shouldn't raise an error and the upgrade procedure should continue.

Additional info:
Tried on two Fedora 15 systems
Comment 1 Panormitis Petrou 2011-10-04 18:49:20 EDT
On my netbook (Acer Aspire One), I fixed the file releases.txt and then I was able to use preupgrade.
After the necessary files/packages were downloaded, preupgrade asked me to reboot.
When I rebooted and Anaconda was starting, the system stopped at:

detecting hardware...
Waiting for hardware to initialize...

The upgrade didn't proceed any further.
Is there any way to solve this?
Comment 2 Richard Hughes 2011-10-05 04:24:13 EDT
(In reply to comment #0)
> The line:
> installmirrorlist=http://mirrors.fedoraproject.org/mirrorlist?pub/fedora/linux/development/16/$basearch/os/
> Should be:
> installmirrorlist=http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/$basearch/os/

Adam, do you know who is responsible for this file on the master mirror?
Comment 3 Panormitis Petrou 2011-10-05 09:25:01 EDT
(In reply to comment #2)
> (In reply to comment #0)
> > The line:
> > installmirrorlist=http://mirrors.fedoraproject.org/mirrorlist?pub/fedora/linux/development/16/$basearch/os/
> > Should be:
> > installmirrorlist=http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/16/$basearch/os/
> 
> Adam, do you know who is responsible for this file on the master mirror?

The file http://mirrors.fedoraproject.org/releases.txt seems to be fixed now.
Comment 4 Richard Hughes 2011-10-05 14:56:38 EDT
(In reply to comment #3)
> The file http://mirrors.fedoraproject.org/releases.txt seems to be fixed now.

Okay, odd. Thanks.
Comment 5 Adam Williamson 2011-10-05 16:23:46 EDT
Kevin Fenzi can fix it, he's the one I bug about it. I bugged him yesterday when I noticed this, which is why it's fixed now.
Comment 6 Morris 2011-10-10 07:24:17 EDT
(In reply to comment #1)
> On my netbook (Acer Aspire One), I fixed the file releases.txt and then I was
> able to use preupgrade.
> After the necessary files/packages were downloaded, preupgrade asked me to
> reboot.
> When I rebooted and Anaconda was starting, the system stopped at:
> 
> detecting hardware...
> Waiting for hardware to initialize...
> 
> The upgrade didn't proceed any further.
> Is there any way to solve this?

here is the same trouble.

and i can't upgrade even with the DVD.
btw, i use the Btrfs file system. is that mattered?
Comment 7 Panormitis Petrou 2011-10-10 08:44:18 EDT
(In reply to comment #6)
> here is the same trouble.
> 
> and i can't upgrade even with the DVD.
> btw, i use the Btrfs file system. is that mattered?

I tried again after few days and it didn't stopped at "Waiting for hardware to initialize...". The upgrade was successful.
I'm not sure why it worked the second time, but perhaps preupgrade downloaded a newer kernel or something.

In my case, I use the Ext4 filesystem.

Note You need to log in before you can comment on or make changes to this bug.