Bug 74342 - Bug in IPv6 MTU setup don't set MTU
Bug in IPv6 MTU setup don't set MTU
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-20 15:50 EDT by Peter Bieringer
Modified: 2014-03-16 22:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-20 15:50:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2002-09-20 15:50:33 EDT
Description of problem:
IPv6 MTU isn't set because of a bug in network-functions-ipv6

Version-Release number of selected component (if applicable):
6.67-1

How reproducible:
Always

Steps to Reproduce:
Try it by specifying an IPv6 MTU in
e.g..ifcfg-eth0
IPV6_MTU=<MTU for IPv6>

	

Actual Results:  IPv6 MTU not set

Expected Results:  IPv6 MTU set

Additional info:

Sorry, bug was introduced by myself more months ago :-(
Here is a patch:

diff -u -r1.1.1.60 -r1.1.1.61
--- network-functions-ipv6      20 Apr 2002 20:06:00 -0000      1.1.1.60
+++ network-functions-ipv6      1 Sep 2002 14:49:24 -0000       1.1.1.61
@@ -2150,7 +2159,7 @@
        ipv6_test testonly || return 2

        # Check whether key exists
-       ipv6_exec_sysctl net.ipv6.conf.$device.mtu=$ipv6_mtu >/dev/null 2>&1
+       ipv6_exec_sysctl net.ipv6.conf.$device.mtu >/dev/null 2>&1
        if [ $? -ne 0 ]; then
                return 3
        fi
Comment 1 Bill Nottingham 2002-11-12 01:36:59 EST
Should be fixed in current CVS, and 6.96-1.

Note You need to log in before you can comment on or make changes to this bug.