Bug 74363 - gome-utils search tool uses \n escaped files find find
gome-utils search tool uses \n escaped files find find
Status: CLOSED DEFERRED
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-utils (Show other bugs)
RC3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-21 17:48 EDT by James Antill
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-21 17:48:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2002-09-21 17:48:07 EDT
Description of Problem:
 gnome-search-tool stupidly uses -print and not -print0

Version-Release number of selected component (if applicable):
gnome-utils-2.0.2-5


How Reproducible:
 Always

Steps to Reproduce:
1. mkdir "`echo -e 'a\nb'`"
2. touch */abcd
3. search for the "abcd" file.

Actual Results:
 crapness

Expected Results:
 non crapness

Additional Information:
 This is easily solved by just passing -print0 to find, and splitting the
results on '\0' instead of '\n'.
Comment 1 Havoc Pennington 2002-09-26 16:59:32 EDT
Moved to http://bugzilla.gnome.org/show_bug.cgi?id=94304

Will get a fix with new gnome-utils tarballs.

Note You need to log in before you can comment on or make changes to this bug.