Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 74365 - notebook bug?
notebook bug?
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gtk2 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
: 82450 (view as bug list)
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-09-21 18:34 EDT by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-03 10:34:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
redhat-config-printer.glade (172.34 KB, text/plain)
2002-09-21 18:35 EDT, Tim Waugh
no flags Details
bug.py (1.61 KB, text/plain)
2002-09-21 18:35 EDT, Tim Waugh
no flags Details
Standalone C test case (2.93 KB, text/plain)
2003-01-15 14:33 EST, Owen Taylor
no flags Details

  None (edit)
Description Tim Waugh 2002-09-21 18:34:14 EDT
Description of Problem: 
I can't figure out why this is happening, and I think it may be a bug.  The 
tabs are not clickable. 
 
Version-Release number of selected component (if applicable): 
gtk2-2.0.6-8 
pygtk-0.6.9-3 
glade2-1.1.1-2 
 
How Reproducible: 
100% 
 
Steps to Reproduce: 
1. Run bug.py 
2. Cancel the dialog. 
3. When the dialog appears the second time, try to switch pages on the 
notebook. 
 
Actual Results: 
Can't. 
 
Expected Results: 
Can. 
 
Additional Information: 
I had to distill this from a much larger test case; making a smaller test case 
from scratch didn't seem to exhibit the problem.
Comment 1 Tim Waugh 2002-09-21 18:35:03 EDT
Created attachment 76806 [details]
redhat-config-printer.glade
Comment 2 Tim Waugh 2002-09-21 18:35:30 EDT
Created attachment 76807 [details]
bug.py
Comment 3 Tim Waugh 2002-09-21 19:08:21 EDT
A workaround seems to be to set the dialog's 'visible' property to 'True' in 
the glade file, and hide it immediately after loading it.
Comment 4 Owen Taylor 2002-10-31 21:12:58 EST
Has been fixed in GNOME CVS - see
http://bugzilla.gnome.org/show_bug.cgi?id=81600
Comment 5 Owen Taylor 2003-01-07 12:40:34 EST
Should be OK in 2.2.0.
Comment 6 Tim Waugh 2003-01-08 12:41:21 EST
Still occurs with gtk2-2.2.0-2, pygtk2-1.99.14-1.
Comment 7 Owen Taylor 2003-01-14 16:38:21 EST
Probably unrelated to the above bug then. I'll try to create a C test
case.
Comment 8 Owen Taylor 2003-01-15 14:33:58 EST
Created attachment 89384 [details]
Standalone C test case
Comment 9 Owen Taylor 2003-01-15 15:39:10 EST
Filed upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103599
and fixed in GNOME CVS.
Comment 10 Tim Waugh 2003-01-22 05:14:11 EST
*** Bug 82450 has been marked as a duplicate of this bug. ***
Comment 11 Owen Taylor 2003-02-03 10:34:29 EST
Should be fixed in gtk2-2.2.1
Comment 12 Jay Berkenbilt 2003-02-11 23:47:06 EST
I'm trying to verify that this fix actually fixes bug 82450.  I'm running
phoebe2 + up2date.  I've downloaded the following from rawhide:

gtk2-2.2.1-1.i386.rpm
gtk2-devel-2.2.1-1.i386.rpm
gtk2-engines-2.2.0-2.i386.rpm
pygtk2-1.99.14-4.i386.rpm
pygtk2-devel-1.99.14-4.i386.rpm
pygtk2-libglade-1.99.14-4.i386.rpm

Now when I run redhat-config-printer, I get

Fatal Python error: could not import _gtk

What else do I have to install to test this?

Note You need to log in before you can comment on or make changes to this bug.