Bug 74366 - "setsysfont" doesn't work under "action"
"setsysfont" doesn't work under "action"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-21 19:23 EDT by Stas Sergeev
Modified: 2014-03-16 22:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-21 19:23:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stas Sergeev 2002-09-21 19:23:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.19 i686)

Description of problem:
During a boot process I get an unreadable messages.

Reason:
There is a line in rc.sysinint, like this:
action $"Setting default font ($SYSFONT): " /sbin/setsysfont

Changing it to lines:
/sbin/setsysfont
action $"Setting default font ($SYSFONT): " /bin/true
fixes the problem. I don't know why "setsysfont" doesn't work
under "action", probably due to some stdin/stdout redirections.
I have verified that "setsysfont" was being executed, but no
results.


Version-Release number of selected component (if applicable):
initscripts-6.53-1


How reproducible:
Always

Steps to Reproduce:
1.Start RH box configured for some language other than english
2.Watch the boot messages
	

Actual Results:  Unreadable messages

Expected Results:  Readable message on my native language

Additional info:
Another problem is that "setsysfont" is called not in the very
beginning of an rc.sysinit, so the part of a boot messages was
still unreadable until I moved the font stuff to the beginning.

And the final problem: I have a /usr on another partition.
That makes /usr/lib/locale unavailable for the part of a boot
process until the local fses are mounted. This makes the first
half of a boot process to write english words and the second
half writes on a local language. The solution can be to move
a /usr/lib/locale to /lib/locale to be present on a root fs,
but this will probably require a glibc recompilling or some
other adjusting work, so I haven't resolved this for me.

If some of that simple bugs can be fixed, I'd be thankfull.
Comment 1 Bill Nottingham 2002-11-12 01:35:46 EST
Should be fixed in 6.96-1 or later

Note You need to log in before you can comment on or make changes to this bug.