Bug 74367 - Ghostscript & gimp-print have circular depency in spec file
Summary: Ghostscript & gimp-print have circular depency in spec file
Status: CLOSED DUPLICATE of bug 69576
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ghostscript (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-22 04:10 UTC by Matt Vanecek
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-22 04:11:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matt Vanecek 2002-09-22 04:10:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
The ghostscript 7.0.5 spec file requires gimp-print-devel to be installed, and
includes gimpprint in the ghostscript Makefile as a library to link to, but the
gimp-print spec file requires ghostscript-devel to be installed, which I cannot
because the spec file requires gimp-print...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I run RH 7.2.  I want to install gimp-print 4.2.2, which requires ghostscript
7.0.5, for ijs stuff.  I downloaded ghostscript 7.0.5 from rawhide.  When I
tried to rebuild ghostscript, rpm told me that I needed gimp-print-devel
installed.  However, I cannot compile/install gimp-print-devel without having
ghostscript-devel, but to get ghostscript-devel, I need to have
gimp-print-devel, which requires ghostscript-devel....etc

The circular dependency makes it difficult to determine if gimp-print is really
and truly needed to compile ghostscript, or if it's OK to remove the dependency
from the ghostscript spec file.  Is it safe to remove the gimp-print stuff from
the ghostscript spec, so I can compile/install ghostscript, so that I can then
compile/install gimp-print?

Additional info:

Comment 1 Tim Waugh 2002-09-30 11:49:09 UTC
Already noted in another bug report.  Thanks. 

*** This bug has been marked as a duplicate of 69576 ***


Note You need to log in before you can comment on or make changes to this bug.