Bug 743694 - system-config-printer on LiveCD (16 beta) complains about FirewallD
Summary: system-config-printer on LiveCD (16 beta) complains about FirewallD
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-05 18:37 UTC by Horst H. von Brand
Modified: 2013-02-13 19:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-13 19:01:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 659722 None None None Never

Description Horst H. von Brand 2011-10-05 18:37:13 UTC
Description of problem:
LiveCD, 16 beta
Trying to configure a network printer (HP LaserJet m1522nf MFP) on the same Ethernet segment, it isn't autodetected. Trying to configure it manually via system-config-printer gives an error message to the effect that FirewallD isn't running. No way out...

Version-Release number of selected component (if applicable):
LiveCD 16 beta

How reproducible:
Always...

Steps to Reproduce:
1. Boot, log in, configure network (manual configuration required here)
2. Select "System Tools" ~~-> "Printers", try to set up a network printer
3.
  
Actual results:
FirewallD isn't running [Is there a firewall?], configuration stops there, can only Cancel.

Expected results:
Set up printer...

Additional info:

Comment 1 Tim Waugh 2011-10-05 20:12:46 UTC
I think you're talking about the GNOME 3 "System Settings" application?

Comment 2 Marek Kašík 2011-10-06 09:54:51 UTC
Hi,

there are two possible reasons for this:

1) you want to install network printer which should be automatically detected
  - if the printer is published by avahi (mdns), you can try to enable and run avahi service to be able to discover it (don't forget to enable mdns service on firewall)

2) the printer is not automatically detectable
  - there is a problem in current control-center that it hides the entry to which you can enter IP address of the printer manually
    - I plan to fix this in control-center-3.2.1 (should be released at 17th of October)

Regards

Marek

Comment 3 Tim Waugh 2011-10-06 10:25:21 UTC
Horst, if you run system-config-printer to configure the printer, does that find it?

Comment 4 Tim Flink 2011-10-06 13:00:49 UTC
I had the same issue described by the reporter running from a beta live image.

I was able to run system-config-printer to configure and add the printer after installing hplip to get the drivers I needed.

Comment 5 Horst H. von Brand 2011-10-07 12:21:11 UTC
(In reply to comment #3)
> Horst, if you run system-config-printer to configure the printer, does that
> find it?

I ran system-config-printer from a gnome-terminal by hand, and goit the above.

Comment 6 Tim Waugh 2011-10-07 12:46:20 UTC
Horst: system-config-printer doesn't have any support for FirewallD and knows nothing about it.  Sure you weren't running the GNOME System Settings application?

Comment 7 Gianluca Sforna 2011-10-11 10:41:01 UTC
I can definitely confirm this is happening with the GNOME System Settings application

Comment 8 Horst H. von Brand 2011-10-11 20:01:28 UTC
(In reply to comment #6)
> Horst: system-config-printer doesn't have any support for FirewallD and knows
> nothing about it.  Sure you weren't running the GNOME System Settings
> application?

I ran system-config-printer from a terminal IIRC.

Comment 9 Tim Waugh 2011-10-12 08:37:38 UTC
Horst: could you run it again please, to check?  system-config-printer knows nothing whatsoever about firewalld.

Comment 10 Fedora End Of Life 2013-01-16 15:52:59 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Fedora End Of Life 2013-02-13 19:01:09 UTC
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.