Bug 74405 - Software RAID partition occasionally mounted as md3 and as ext3 standalone partition
Summary: Software RAID partition occasionally mounted as md3 and as ext3 standalone pa...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: mount   
(Show other bugs)
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-23 18:29 UTC by Larry Troan
Modified: 2016-04-18 09:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-23 18:38:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
df command output (618 bytes, text/plain)
2002-09-23 18:32 UTC, Larry Troan
no flags Details
fdisk -l output (2.30 KB, text/plain)
2002-09-23 18:32 UTC, Larry Troan
no flags Details
fstab output (1.12 KB, text/plain)
2002-09-23 18:33 UTC, Larry Troan
no flags Details
mount command output (411 bytes, text/plain)
2002-09-23 18:34 UTC, Larry Troan
no flags Details
raidtab file (1.83 KB, text/plain)
2002-09-23 18:35 UTC, Larry Troan
no flags Details
AS kernel version (uname -a output) (76 bytes, text/plain)
2002-09-23 18:36 UTC, Larry Troan
no flags Details
gahagan/johnson suggested workaround - fstab without LABELs (1.12 KB, text/plain)
2002-09-23 18:37 UTC, Larry Troan
no flags Details

Description Larry Troan 2002-09-23 18:29:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020424

Description of problem:
Customer has three 36GB HDs and has defined software RAID=1 (mirror) for all
file systems. Each fs on sda is mirrored on sdb and sdc. About 50% of time, /var
is mounted as md3 AND as /dev/sda6 causing corruption detection on next reboot.
-----
Workaround was to remove all labels from /etc/fstab. Several reboots later, were
unable to duplicate problem.
-----
See Issue Tracker 7500 for full details.
-----
Bugzilla 70353 was taken out against Milan and appears to be similar problem.
-----
AS rpm is util-linux-2.11f-17.1.i386.rpm.




Version-Release number of selected component (if applicable):
mount-2.11g-5

How reproducible:
Sometimes

Steps to Reproduce:
1.Customer defined all partitions as mirrored software raid (1) across three
HDs. See attached files for details
2.booting system resulted in df command displaying /dev/md3 as /var and
/dev/sda6 as /var which was one of the mirrored partitions for /var.
3.Writing into this partition as /dev/sda6 caused fsck on reboot.
4.Occurred about 50% of time.
5.Engineering suggested removing all labels from fstab (fstab.new attachment)
and problem appeared to go away.  

	

Actual Results:  Per #2 above, booting system resulted in df command displaying
/dev/md3 as /var and /dev/sda6 as /var which was one of the mirrored partitions
for /var.

Expected Results:  Should not be able to mount one partition of a Software Raid
1 as a standalone partition. mount should prevent this from happening as I'm
told 70353 did for Milan.

Additional info:

See attached files -- nothing looks wrong but sda6 was incorrectly mounted about
50% of the time causing an fsck in the following reboot (due to non-matching
mirrors).

Comment 1 Larry Troan 2002-09-23 18:32:13 UTC
Created attachment 76904 [details]
df command output

Comment 2 Larry Troan 2002-09-23 18:32:59 UTC
Created attachment 76905 [details]
fdisk -l output

Comment 3 Larry Troan 2002-09-23 18:33:37 UTC
Created attachment 76906 [details]
fstab output

Comment 4 Larry Troan 2002-09-23 18:34:35 UTC
Created attachment 76907 [details]
mount command output

Comment 5 Larry Troan 2002-09-23 18:35:19 UTC
Created attachment 76908 [details]
raidtab file

Comment 6 Larry Troan 2002-09-23 18:36:52 UTC
Created attachment 76909 [details]
AS kernel version (uname -a output)

Comment 7 Larry Troan 2002-09-23 18:37:59 UTC
Created attachment 76910 [details]
gahagan/johnson suggested workaround - fstab without LABELs

Comment 8 Elliot Lee 2002-10-22 13:55:29 UTC
fstab without labels is the workaround, and the fix is in 8.0.


Note You need to log in before you can comment on or make changes to this bug.