Bug 74408 - gnome-terminal does not display data with the 'less' command properly
Summary: gnome-terminal does not display data with the 'less' command properly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
: 74514 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-23 19:31 UTC by berto
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version: blah
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-11 11:39:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description berto 2002-09-23 19:31:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
when using the command: 

less 'filename' 
or
man <command-name>

nothing is displayed on the screen.  if the down arrow is hit, nothing shows up
until the up arrow is hit.  the same happens with pagedown; nothing will happen
until pageup is hit.  for example, if you want to scroll down a page, you'd have to:

pagedown
pagedown
pageup

after that, you'll finally see the expected text.  i tried these commands using
xterm and they work fine.

Version-Release number of selected component (if applicable): gnome-terminal-2.0.1-3


How reproducible:
Always

Steps to Reproduce:
1. less a file or man a command
2. view the results

	

Actual Results:  nothing is displayed and scrolling acts strange

Expected Results:  buffer scrolling should work like in old versions of
gnome-terminal or other terminal emulators like xterm.

Additional info:

Comment 1 Havoc Pennington 2002-09-23 19:38:50 UTC
This should be fixed with the final vte

Comment 2 Nalin Dahyabhai 2002-10-18 00:34:50 UTC
*** Bug 74514 has been marked as a duplicate of this bug. ***

Comment 3 Warren Togami 2005-09-11 11:39:29 UTC
Part of what is described here is normal less behavior in any terminal.  The
rest has since been fixed a long time ago.


Note You need to log in before you can comment on or make changes to this bug.