Bug 74411 - rpm won't install rpm packages built for "pentium3"
rpm won't install rpm packages built for "pentium3"
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-23 16:20 EDT by gthornock
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-23 16:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gthornock 2002-09-23 16:20:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
rpmbuild accepts "--target pentium3" as a compile option, and gcc 3.2 knows what
to do to compile for pentium3.  However, the current version of rpm won't
install *.pentium3.rpm, it gives an error message indicating that the rpm is
intended for a pentium3 architecture.  (Which, in fact, it is, but rpm doesn't
seem to realize what a pentium3 is.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Grab a random .src.rpm file
2. rpmbuild --rebuild --target pentium3 *.src.rpm
3. rpm -Uvh *.pentium3.rpm
	

Actual Results:  There's an error message indicating that the rpm file is for a
pentium3 architecture.  (It is, and the computer I'm using is, in fact, a
Pentium 3.)  The rpm is not installed.

Expected Results:  I expected the rpm to install and function correctly.

Additional info:
Comment 1 Jeff Johnson 2002-09-24 09:41:37 EDT
Yes, "pentium3" is not known to rpm. You're
probably looking for --target i686.
Comment 2 gthornock 2002-09-24 10:16:09 EDT
That's fine, but if that's the case, then why does rpmbuild accept --target
pentium3?

Note You need to log in before you can comment on or make changes to this bug.