Bug 74416 - ping prints "WARNING: failed to install [...]"
Summary: ping prints "WARNING: failed to install [...]"
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iputils   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-23 22:42 UTC by Pete Zaitcev
Modified: 2015-03-05 01:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-04 15:03:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pete Zaitcev 2002-09-23 22:42:21 UTC
Description of Problem:

ping sometimes prints:

WARNING: failed to install socket filter
: Protocol not available

Version-Release number of selected component (if applicable):

iputils-20020124-3

How Reproducible:

It does this in different circumstances, but the easiest way
to reproduce is to run two pings in two terminal windows.

Steps to Reproduce:
1. Run "ping -n -M dont -s 200 151.164.129.3" in one window.
2. Start "ping -n -M dont -s 200 151.164.129.3" in other window.
3. [Can interrupt both pings and retry if message does not appear]

Actual Results:

[zaitcev@niphredil zaitcev]$ !ping
ping -n -M dont -s 200 151.164.129.3
PING 151.164.129.3 (151.164.129.3) from 192.168.128.9 : 200(228) bytes of data.
208 bytes from 151.164.129.3: icmp_seq=1 ttl=38 time=77.9 ms
208 bytes from 151.164.129.3: icmp_seq=2 ttl=38 time=76.6 ms
208 bytes from 151.164.129.3: icmp_seq=3 ttl=38 time=77.0 ms
208 bytes from 151.164.129.3: icmp_seq=4 ttl=38 time=77.1 ms
WARNING: failed to install socket filter
: Protocol not available
208 bytes from 151.164.129.3: icmp_seq=5 ttl=38 time=77.4 ms
208 bytes from 151.164.129.3: icmp_seq=6 ttl=38 time=76.6 ms
208 bytes from 151.164.129.3: icmp_seq=7 ttl=38 time=74.4 ms
208 bytes from 151.164.129.3: icmp_seq=8 ttl=38 time=78.2 ms

--- 151.164.129.3 ping statistics ---
8 packets transmitted, 8 received, 0% loss, time 7074ms
rtt min/avg/max/mdev = 74.481/76.958/78.262/1.140 ms
[zaitcev@niphredil zaitcev]$ 

Expected Results:

Same, but without the warning message.

Additional Information:
	
1. It seems that both pings continue to function despite the
warning, because sequence numbers look correct in both windows.

2. The warning message itself has an extra newline. Make sure
the root cause is fixed before you fix the message though :)

3. The example above was tested with Marcelo tree, 2.4.19.
Same story with 2.4.18-10 etc. Seems like a generic error.

Comment 1 Phil Knirsch 2002-10-04 15:03:26 UTC
Could you try that on a Red Hat Linux 8.0 machine? I just tried the exact same
thing on my machines here and it works without the warning.

Thanks,

Read ya, Phil

Comment 2 Pete Zaitcev 2002-10-09 08:15:47 UTC
Seems to be fixed on RHL 8.0.



Note You need to log in before you can comment on or make changes to this bug.