Bug 744371 - Eclipse triggers JVM segfault
Eclipse triggers JVM segfault
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-08 02:09 EDT by Casey Dahlin
Modified: 2014-06-18 04:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 10:48:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The crash report file (74.58 KB, text/x-log)
2011-11-18 05:00 EST, Paulo Fidalgo
no flags Details
Comment (81.47 KB, text/plain)
2011-10-08 02:09 EDT, Casey Dahlin
no flags Details

  None (edit)
Description Casey Dahlin 2011-10-08 02:09:18 EDT
Created attachment 915372 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 Andrew Overholt 2011-10-12 08:21:52 EDT
Good 'ol webkit.  Sami, is this the same problem you were looking into the other day?

Casey, if you start eclipse from a terminal with the options "-data /tmp/testFor744371", does it crash on startup?  The first time you start with a new workspace (the -data option) it should show the welcome screen which is rendered with the browser just like JavaDoc hovers, etc.
Comment 2 Sami Wagiaalla 2011-10-12 09:27:50 EDT
It looks very similar.

The reproducer for my bug was start eclipse with a clean workspace
For example:

  eclipse -data /tmp/testFor744371

As soon as I close the welcome screen I get the crash.

To make this go away I did a full yum update. It must have been a webkit or gtk one that fixed it. Try that and let us know.
Comment 3 Casey Dahlin 2011-10-12 20:44:50 EDT
reproducing as suggested did produce a crash immediately. I'll try a yum update and see if that helps (I tried just after I first saw the bug and it did not).
Comment 4 Casey Dahlin 2011-10-12 20:53:14 EDT
Full yum update and reboot did not help.

Also I found this: https://bugs.eclipse.org/bugs/show_bug.cgi?id=341825
Comment 5 Sami Wagiaalla 2011-10-13 10:45:09 EDT
Hmm... I experienced this problem on f16 and I cannot reproduce it with an up todate f15 are there any f16 packages that may have leaked into your system ?
Comment 6 Casey Dahlin 2011-10-13 17:31:01 EDT
[sadmac@foucault ~]$ rpm -qa |grep fc16
[sadmac@foucault ~]$
Comment 7 Paulo Fidalgo 2011-11-16 04:35:30 EST
I experience the same with FC16:

# JRE version: 6.0_22-b22
# Java VM: OpenJDK 64-Bit Server VM (20.0-b11 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea6 1.10.4
# Distribution: Fedora release 16 (Verne), package fedora-60.1.10.4.fc16-x86_64
# Problematic frame:
# C  [libgobject-2.0.so.0+0x186d0]  g_object_get_qdata+0x20

Altough if I start eclipse with -data parameter it starts normally.
Comment 8 Andrew Overholt 2011-11-17 13:19:13 EST
So this is a crasher in the WebKit integration of SWT?  Alex/Sami, can you confirm?
Comment 9 Alexander Kurtakov 2011-11-17 13:24:28 EST
Paulo's comment doesn't look like a webkit issue. Paulo, you do use eclipse installed from fedora repositories, right?
Comment 10 Paulo Fidalgo 2011-11-18 04:59:35 EST
Yes, it's from the repositories.
Here is the info:
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00000032f54186d0, pid=3297, tid=140603627333376
#
# JRE version: 6.0_22-b22
# Java VM: OpenJDK 64-Bit Server VM (20.0-b11 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea6 1.10.4
# Distribution: Fedora release 16 (Verne), package fedora-60.1.10.4.fc16-x86_64
# Problematic frame:
# C  [libgobject-2.0.so.0+0x186d0]  g_object_get_qdata+0x20
#
# An error report file with more information is saved as:
# /home/fidalgo/hs_err_pid3297.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla

I will attach the report file.

I've removed $HOME/.eclipse, started eclipse and then selected an existing workspace. If I start eclipse with the -data switch it starts normally.
My system contains the latest updates, but if more information is needed I can provide, even if it consists in running in debug or something.
Comment 11 Paulo Fidalgo 2011-11-18 05:00:24 EST
Created attachment 534369 [details]
The crash report file
Comment 12 Fedora End Of Life 2012-08-07 10:48:12 EDT
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.