Bug 7444 - DHCP server - Windows clients interoperability problem
DHCP server - Windows clients interoperability problem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-30 09:54 EST by jkrzyszt
Modified: 2016-03-15 10:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-01 06:19:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jkrzyszt 1999-11-30 09:54:45 EST
Tracing the problem of Windows DHCP clients not getting their leases,
i got the following with tcpdump:

-------------
12:55:17.362316 B 192.168.211.64.bootpc > 255.255.255.255.bootps:
xid:0xf0660c1d vend-rfc1048 T53:3 T51:269352960 T50:1087613120
T55:1.28.2.3.15.6.12 [tos 0x10]

12:55:17.371551 > 0:0:0:0:0:0 sap 10 > 0:0:c0:db:78:66 sap 45 I
(s=0,r=36,C) len=324
                         0000 0000 1011 a996 0000 0000 ffff ffff
                         0043 0044 0134 c433 0201 0600 f066 0c1d
                         0000 8000 0000 0000 c0a8 d340 c0a8 d3e0
                         0000 0000 0000 e856 e694 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 0000 0000 0000 0000 0000 0000
                         0000 0000 6382 5363 3501 0536 0400 0000
                         0033 0400 000e 1001 04ff ffff 0003 04c0
                         a8d3 fe0f 0974 6973 2e69 636e 6574 0604
                         c0a8 d301 ff00 0000 0000 0000 0000 0000
                         0000 0000
------------------
Looks like DHCP answers are not UDP packets. Linux DHCP clients do
recognize such answers, but Windows do not.
Comment 1 jkrzyszt 1999-12-01 06:19:59 EST
The source of my problem was incorrect server-identifier statement. Sorry.
Comment 2 openshift-github-bot 2016-03-15 10:33:24 EDT
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/d4c3344332fcafd350ba023e7b57d6386e2a3bf0
Fix for bugz https://bugzilla.redhat.com/show_bug.cgi?id=1316698
and issue #7444
  o Fixes as per @pweil- and @marun review comments.
  o Fixes as per @smarterclayton review comments.

Note You need to log in before you can comment on or make changes to this bug.