This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 744544 - virtio cannot transfer all guest anaconda logs to host
virtio cannot transfer all guest anaconda logs to host
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 745711
  Show dependency treegraph
 
Reported: 2011-10-09 06:16 EDT by Hongqing Yang
Modified: 2014-09-30 19:40 EDT (History)
8 users (show)

See Also:
Fixed In Version: lorax-16.4.7-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 745711 (view as bug list)
Environment:
Last Closed: 2011-10-12 04:28:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
analog (7.92 KB, text/plain)
2011-10-09 06:16 EDT, Hongqing Yang
no flags Details
anaconda logs (840.00 KB, application/x-tar)
2011-10-09 06:42 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2011-10-09 06:16:37 EDT
Created attachment 527084 [details]
analog

Description of problem:
It fails to transfer all anaconda logs of guest to the host by serial virtio. only the syslog is transferred.

Version-Release number of selected component (if applicable):

host is F15 with libvirt-0.8.8-7.fc15.x86_64, virt-manager-0.8.7-6.fc15.noarch
guest is F16 Beta gold (F16 beta rc4)

How reproducible:
100%

Steps to Reproduce:
1. add virtio-serial port on the guest with virsh edit
2. run analog to start listening to the guest
3. start guest
  
Actual results:


Expected results:


Additional info:
This blocks the Fedora installation test automation project, hope you can give it high priority. Thanks.
Comment 1 Hongqing Yang 2011-10-09 06:42:54 EDT
Created attachment 527085 [details]
anaconda logs
Comment 2 Ales Kozumplik 2011-10-10 11:14:02 EDT
I can confirm this, though this is not a bug in analog. Apparently the rsyslog format of forwarded messages has changed between the two versions and what is forwarded from F16 rsyslogd (the one running in your guest) is not correctly parsed by the receiving F15 rsyslogd (the one where analog is running). You should be able to confirm this e.g. by looking at debug_unknown_source.log which contains all the messages where we failed to recognize the tag.

Reassigning to rsyslogd which maintainer might or might not be able to help you.

The easiest fix for you is in any case upgrading your host rsyslogd to the same version the tested guest is running.
Comment 3 Ales Kozumplik 2011-10-11 09:09:02 EDT
We clarified this with theinric and the error is not because of a new rsyslog version but rather due to changed environment in F16 --- something we can fix in the image generation.
Comment 5 Ales Kozumplik 2011-10-12 04:28:23 EDT
Fixed by e61f3b23d47903b30ac0ce591a200dc5edc4f979. This will be part of the first f17 compose.

Hongqing,

Will it be OK to have this in F17 only?
Comment 6 Hongqing Yang 2011-10-12 22:24:09 EDT
(In reply to comment #5)
> Fixed by e61f3b23d47903b30ac0ce591a200dc5edc4f979. This will be part of the
> first f17 compose.
> 
> Hongqing,
> 
> Will it be OK to have this in F17 only?

Ales, 
It would be better if you can correct it in F16 Final, since the new environment in F16, I have to update the test scripts accordingly, so I need a working media to test. Thanks.
Comment 7 Fedora Update System 2011-10-17 13:24:59 EDT
lorax-16.4.7-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lorax-16.4.7-1.fc16
Comment 8 Fedora Update System 2011-10-20 00:01:44 EDT
lorax-16.4.7-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.