Bug 74458 - ATI Rage 128 mobility video card crashes X server
Summary: ATI Rage 128 mobility video card crashes X server
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 82779
TreeView+ depends on / blocked
 
Reported: 2002-09-24 18:27 UTC by Chris L. Gray
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 17:40:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 Log (56.62 KB, text/plain)
2002-09-24 18:28 UTC, Chris L. Gray
no flags Details
XF86Config (3.55 KB, application/octet-stream)
2002-12-14 01:32 UTC, Chris L. Gray
no flags Details

Description Chris L. Gray 2002-09-24 18:27:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
ATI Rage 128 mobility video card crashes X server. The video card is on a Compaq
Presario 1800 laptop. This began on first boot after install. I am having to use
the 'vesa' drivers to use X at all.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use 'redhat-confic-xfree86 --reconfigure' to add 'r128' back as the default
driver for my card.
2.Use 'startx' from the command line.
3.X attempts to start, screen flickers, server crashes and gives output,  'no
screens were found'
	

Actual Results:  X attempts to start, screen flickers, server crashes and gives
output,  'no screens were found'.
	

Expected Results:  X server should have launched.

Additional info:

Comment 1 Chris L. Gray 2002-09-24 18:28:24 UTC
Created attachment 77064 [details]
XFree86 Log

Comment 2 Alexander Larsson 2002-10-02 06:44:54 UTC
The logs look ok to me at least. Can you attach the /etc/X11/XF86Config file too?

mharris: This looks like yours.


Comment 3 Chris L. Gray 2002-12-02 19:20:52 UTC
Where do we stand on this? I am new to Bugzilla, what can I do to help things 
along?

Chris Gray

Comment 4 Mike A. Harris 2002-12-02 19:34:54 UTC
The current status is: Waiting for the file attachment requested by alexl


Comment 5 Brent Fox 2002-12-13 22:17:55 UTC
Chris, are you still seeing the problem?  If so, can you please attach the
/etc/X11/XF86Config file?  Otherwise, we're kind of stuck on this issue.

Comment 6 Chris L. Gray 2002-12-14 01:32:34 UTC
Created attachment 88717 [details]
XF86Config

Comment 7 Brent Fox 2002-12-20 09:14:30 UTC
mharris: can you look at this now that the config file has been attached?

Comment 8 Brent Fox 2003-01-20 22:54:51 UTC
I'm changing the component to XFree86 since it looks like the config file is
valid.  Maybe the driver is at fault.

Comment 9 rodrigo 2003-08-05 00:43:59 UTC
Hello,
I am new in Linux running RedHat 8.0 and last thing I did is running up2date 
from command line and when I wanted to startx it won't start. Screen flickers 
and will give this error:
XIO: fatal IO error 104 (connextion reset by peer) on X server "0:0" after 0 
requests (0 known processed) with 0 events remaining.
any idea?
Rodrigo

Comment 10 Mike A. Harris 2004-09-24 17:40:51 UTC
We believe this issue to be resolved in our currently shipping
OS releases.  Please upgrade to Fedora Core 2 or later, and if this
issue turns out to still be reproduceable, please file a bug report
in the X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.


Note You need to log in before you can comment on or make changes to this bug.