Bug 744589 - long double redirects unavailable in <math.h> and <complex.h> on ARM
long double redirects unavailable in <math.h> and <complex.h> on ARM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-09 12:23 EDT by Daniel Drake
Modified: 2016-11-24 11:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-09 12:09:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alternative fix (490 bytes, patch)
2011-10-26 17:42 EDT, Daniel Drake
no flags Details | Diff

  None (edit)
Description Daniel Drake 2011-10-09 12:23:48 EDT
Functions such as creall() and cimagl() are not available on ARM (reproduced with glibc-2.14-7), due to failing to meet these preprocessor conditions in complex.h:

#if (__STDC__ - 0 || __GNUC__ - 0) \
    && (!defined __NO_LONG_DOUBLE_MATH || defined __LDBL_COMPAT)

Packages which use these functions and use -Werror during build (such as libmpc) are failing to compile as a result.

The use of -Werror is indeed questionable, but this does seem to be a glibc bug. Probably this one: http://sourceware.org/bugzilla/show_bug.cgi?id=10103

I confirmed that Jakub's patch still hasn't been applied in glibc HEAD.
Comment 1 Daniel Drake 2011-10-26 17:42:00 EDT
Created attachment 530394 [details]
alternative fix

This alternative fix was submitted by a Fedora-ARM contributor. Not sure if it is better or worse than Jakub's patch from 2009.

Please let us know how we can help this issue get fixed.
Comment 2 Jakub Jelinek 2011-10-26 18:01:19 EDT
That is a bad idea, because then you penalize glibc quite a bit.
Comment 3 Daniel Drake 2011-10-26 18:06:30 EDT
OK, thanks for the quick response. Is your 2009 patch the right way to go then? Would it help you if we rediff/retest that patch against current glibc?
Comment 4 Fedora Admin XMLRPC Client 2011-11-14 14:45:16 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Jeff Law 2012-02-09 12:09:15 EST
Looks like this was fixed in the upstream sources on 11/4 and thus would be included in rawhide.

If this is still an issue, please reopen the report with further details as to why the upstream fix was insufficient.

Thanks,
Jeff

Note You need to log in before you can comment on or make changes to this bug.