Bug 744651 - package file conflict.
package file conflict.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-09 21:52 EDT by Adrin Jalali
Modified: 2011-10-09 22:13 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-09 22:03:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrin Jalali 2011-10-09 21:52:25 EDT
To be able to run skype on fedora, I need to install package 
1:qt-4.8.0-0.11.beta1.fc16.i686

but this is what I get:

# yum --setopt=protected_multilib=false install 1:qt-4.8.0-0.11.beta1.fc16.i686
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package qt.i686 1:4.8.0-0.11.beta1.fc16 will be installed
--> Processing Dependency: libcrypto.so.10 for package: 1:qt-4.8.0-0.11.beta1.fc16.i686
--> Processing Dependency: libsqlite3.so.0 for package: 1:qt-4.8.0-0.11.beta1.fc16.i686
--> Processing Dependency: libssl.so.10 for package: 1:qt-4.8.0-0.11.beta1.fc16.i686
--> Running transaction check
---> Package openssl.i686 0:1.0.0e-1.fc16 will be installed
---> Package sqlite.i686 0:3.7.7.1-1.fc16 will be installed
--> Processing Dependency: libtinfo.so.5 for package: sqlite-3.7.7.1-1.fc16.i686
--> Processing Dependency: libreadline.so.6 for package: sqlite-3.7.7.1-1.fc16.i686
--> Processing Dependency: libncurses.so.5 for package: sqlite-3.7.7.1-1.fc16.i686
--> Running transaction check
---> Package ncurses-libs.i686 0:5.9-2.20110716.fc16 will be installed
---> Package readline.i686 0:6.2-2.fc16 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================================
 Package                                   Arch                              Version                                                Repository                           Size
==============================================================================================================================================================================
Installing:
 qt                                        i686                              1:4.8.0-0.11.beta1.fc16                                fedora                              4.3 M
Installing for dependencies:
 ncurses-libs                              i686                              5.9-2.20110716.fc16                                    fedora                              254 k
 openssl                                   i686                              1.0.0e-1.fc16                                          fedora                              1.4 M
 readline                                  i686                              6.2-2.fc16                                             fedora                              182 k
 sqlite                                    i686                              3.7.7.1-1.fc16                                         fedora                              337 k

Transaction Summary
==============================================================================================================================================================================
Install       5 Packages

Total size: 6.4 M
Installed size: 6.4 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  package qt-1:4.8.0-0.12.20111002.fc16.x86_64 (which is newer than qt-1:4.8.0-0.11.beta1.fc16.i686) is already installed
  file /usr/share/doc/qt-4.8.0/LICENSE.LGPL from install of qt-1:4.8.0-0.11.beta1.fc16.i686 conflicts with file from package qt-1:4.8.0-0.12.20111002.fc16.x86_64
  file /usr/share/qt4/translations/qt_ja.qm from install of qt-1:4.8.0-0.11.beta1.fc16.i686 conflicts with file from package qt-1:4.8.0-0.12.20111002.fc16.x86_64
  file /usr/share/qt4/translations/qt_ru.qm from install of qt-1:4.8.0-0.11.beta1.fc16.i686 conflicts with file from package qt-1:4.8.0-0.12.20111002.fc16.x86_64

Error Summary
-------------
Comment 1 Kevin Kofler 2011-10-09 22:03:51 EDT
Your qt.x86_64 is from updates-testing, and now you have updates-testing disabled. You cannot install an older qt.i686 than qt.x86_64, they must be the same version. So either downgrade qt.x86_64 to the version from the stable updates or reenable updates-testing.

(Yet another casuality of the braindead "updates-testing is enabled by default for prereleases and gets disabled by default shortly before the release" policy I've been complaining about ever since it got introduced. But this is broken by design, there is no bug.)
Comment 2 Kevin Kofler 2011-10-09 22:07:14 EDT
Though actually, I don't see updates-testing having been disabled in fedora-release yet, so it looks like you disabled it. It's not that easy to get off updates-testing. You have to run "yum distro-sync" if you want to downgrade to stable packages. Or next time, disable updates-testing BEFORE you install ANY updates.
Comment 3 Adrin Jalali 2011-10-09 22:12:34 EDT
I did not disable updates-testing, see:

# yum repolist
repo id                                                                      repo name                                                                                  status
adobe-linux-x86_64                                                           Adobe Systems Incorporated                                                                      2
fedora                                                                       Fedora 16 - x86_64                                                                         24,917
google-talkplugin                                                            google-talkplugin                                                                               1
rpmfusion-free-rawhide                                                       RPM Fusion for Fedora Rawhide - Free                                                          394
rpmfusion-nonfree-rawhide                                                    RPM Fusion for Fedora Rawhide - Nonfree                                                       164
updates-testing                                                              Fedora 16 - x86_64 - Test Updates                                                           6,669
repolist: 32,147
Comment 4 Adrin Jalali 2011-10-09 22:13:22 EDT
I even tryed to enable updates repo and install the package, but that didn't work either.

Note You need to log in before you can comment on or make changes to this bug.